Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Quick question, I have a problem in that my K-9 mail application is not finding any of my Google Mail IMAP folders/labels. Now I can send and receive messages without problem, however I'm curious as to why K-9 cannot find any of my folders such as [Google Mail]/-Poeticemails

Any ideas? Am I getting confused between labels/folder and the two aren't interchangable?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

Have you enabled the visibility of these labels/folders from the IMAP section of options in the main Gmail web interface. Advanced IMAP controls were recently rolled out to all users, so certain labels/folders may have been deemed hidden.

Click SETTINGS and then within the LABELS section, check mark those boxes whose labels you want shown as IMAP folders by selecting SHOW IN IMAP.

===========

UPDATE: Also check within K9 ACCOUNT SETTINGS > FOLDERS and make sure certain folders aren't hidden.

share|improve this answer
    
Yeah, checked that. All my folders except "Chat" are enabled. Tried unchecking them, then re-enabling to no luck. –  wonea Jun 8 '11 at 14:02
1  
In that case, try wiping everything from K9 and setting up your account again. –  Sparx Jun 8 '11 at 17:02
    
That finally did it, thanks! Something must of gone wonky the first setup. –  wonea Jun 9 '11 at 9:32
    
What in particular worked? Clean re-install or folder settings? –  Sparx Jun 9 '11 at 13:43
1  
Changing the folder settings didn't work. So from the accounts page, I brought up the Accounts Options page, then clicked on Remove Account. I re-readded the account this time, and made sure all the settings where correct. My hunch is last time I used the automatic setup for my gmail account and this is where things went wrong –  wonea Jun 10 '11 at 8:34
add comment

I was having the same problem (with a non-gmail IMAP account), what worked for me was to monkey with it. Set all the folder settings to display only subscribed folders. Then refresh folders. Then change it to display all folders. Now I can see my newer IMAP folders.

So ... if you're loathe to re-install your account, try just changing the folder display settings around and then changing them back.

share|improve this answer
add comment

I went to the folder list. I then hit my menu button & a new menu popped up that said "refresh folders" on the bottom. When I did that, it grabbed the new folders I created & removed the ones I had deleted (from using previous webmail programs).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.