Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Recently Google started to check the “allow automatic updating” for their apps without being asked, which I hate. I have to deactivate it for each app separately.

But more importantly this pushed Google Books onto my phone, which I don´t need and wastes precious 4 MB internal memory.

And here comes the nasty twist: Google book is not actually available for my System (for whatever reason). So I can´t get the applications market page to un-check the “allow automatic updating”.

This leaves me wondering: is there a way to deactivate the “allow automatic updating” for all applications?

share|improve this question
    
Automatic updating, as well as Google's backup service, has never worked on my phone at all. If I find out why and it's something you can turn on and off, I'll let you know! –  Matthew Read Jun 9 '11 at 14:39
    
@Matthew Read, I think it may be because of TouchWiz. Once I installed CyanogenMod, it pulled down all my apps from the market and installed them, and I wish it didn't, I have a lot installed :), it locked up my phone for a while. –  Ryan Conrad Jun 9 '11 at 22:37
    
There used to be an app available on XDA Forums that allowed a root user to bulk toggle auto update on/off for all apps. However, a recent Market update has broken functionality. –  Sparx Jun 10 '11 at 9:07
add comment

7 Answers 7

Here's the trick:

  1. Use an app manager to force stop the Play Store, then clear all the data.
  2. Go to the Play Store's settings, then deselect "Auto update apps by default"
share|improve this answer
3  
Why do you have to force close it? –  roxan Sep 22 '12 at 2:36
add comment

Titanium Backup (root only) has "Market Tools". One of these tools is "Market Auto Updates" which presents a list of all your apps with their checkboxes for auto-updates. You can sort the enabled apps to the top, and you can "deselect all" to disable automatic updating for all apps.

share|improve this answer
add comment

Market version 3.3.11 now has a setting called "Auto-update apps". Enabling it will effectively set each individual app associated with the account to auto-update, and disabling it will of course do the opposite. This setting is found by simply going into the Market's settings (Menu Button->Settings on phones, or use the top-right action bar on Honeycomb).

You can read about the release here. It also has links that could help you sideload the update if it is not automatically available to you.

share|improve this answer
add comment

You could use a program like Droidwall to block Market's internet access, this should keep it from installing/uninstalling programs.

share|improve this answer
add comment
up vote 0 down vote accepted

There bitter truth is there is none option to switch all automatic updated off in one go.

I solved my particular problem by rooting the phone. Since no exploit is known for 2.3.4 I had to unlock the phone. This in turn meant that both Amazon MP3 and Google Books stopped updating themselves.

Which is one way to solve the problem. Still I removed the files using the following Script:

#!/opt/local/bin/zsh

setopt No_Err_Exit

adb -d uninstall com.amazon.mp3
adb -d uninstall com.google.android.apps.books

setopt Err_Exit

adb -d pull /system/app/com.amazon.mp3.apk Originals/com.amazon.mp3.apk
adb -d pull /system/app/BooksPhone.apk     Originals/BooksPhone.apk
adb -d pull /system/app/BooksPhone.odex    Originals/BooksPhone.odex

adb -d shell <<-EOF
    su
    mount -o remount,rw /dev/block/mtdblock3 /system

    busybox rm -v /system/app/com.amazon.mp3.apk
    busybox rm -v /system/app/BooksPhone.apk
    busybox rm -v /system/app/BooksPhone.odex

    mount -o remount,ro /dev/block/mtdblock3 /system

    busybox rm -v    /data/dalvik-cache/system@app@com.amazon.mp3.apk@classes.dex
    busybox rm -v -r /data/data/com.amazon.mp3
    busybox rm -v -r /data/data/com.google.android.apps.books

    exit
    exit
EOF

# vim: set nowrap tabstop=4 shiftwidth=4 softtabstop=4 noexpandtab :
# vim: -d set textwidth=0 filetype=zsh foldmethod=marker nospell :

Warning: This is script from the “If you can't understand it you should not be using it” category.

share|improve this answer
add comment

When in android market select my apps. u will see all the applications installed. select tha one u want to disable automatic updates. u will see a small checkbox at the bottom. uncheck it.

share|improve this answer
    
Which part of »So I can't get the applications market page to un-check the “allow automatic updating”.« did you not understand? — And in the question title is one word marked with double stars. I did that because I thought this is the most important aspect of my question. Something to distinguished my Question from similar questions. — Anyway, welcome to stack overflow. — Hint: Wait until your answer is at -3 then delete it to get the “peer pressure” honour batch. –  Martin Jun 18 '11 at 12:21
add comment

If you have Titanium Backup installed you could try and Freeze the program Software Update.

share|improve this answer
2  
Good thinking, but for Titanium Backup the phone needs to be rooted. And once you did that you have an even cooler way to solve the problem: adb shell su rm /system/app/BooksPhone.apk ;-) — Don't forget to make a backup copy fist just in case Google manages a 2.3.5 release. –  Martin Jun 18 '11 at 12:44
    
This highlights that on most phones, the space used in /system isn't space that a user can normally use, anyway. So the 4 MB is actually zero impact. –  TREE Nov 28 '11 at 19:38
add comment

protected by Community Jun 1 '13 at 16:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.