Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm not sure if this is a question I should be asking my carrier or not, but hopefully someone might be able to point me in the right direction. I recently switched to CyanogenMod version 7, and the experience has been great, for the most part. I have voicemail service from my mobile provider, and under Settings > Call Settings > Voicemail settings I have my voicemail number set. However, if I let a call go to voicemail, my phone will indicate that I have missed a call, but not that the message has gone to voicemail.

How can I get the voicemail indicator to appear in CyanogenMod 7?


share|improve this question
What device are you using? Are you using a "Visual Voice Mail" app? Are you using a nightly version of CyanogenMod? – Ryan Conrad Jun 10 '11 at 19:54

This looks like it could be a known, or at least reported, issue, depending on the device you are using.

A few users report that on some carriers (looks like mostly in Canada) they have the exact issue with the Desire Z, running CyanogenMod.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.