Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Hello good people of stack exchange, I am having trouble setting up my Ubuntu 11.04 boot to use for app development on a hardware device. I have followed the instructions here to try and recongnize the phone. However, when I run ADB devices or in eclipse, the device is listed as ?????? and can not be used to install an app to. Any advice?

share|improve this question
    
What device are you using? –  CaseyB Jun 12 '11 at 15:41
add comment

3 Answers

up vote 1 down vote accepted

The problem is that you ran adb as an underprivileged user. So when adb server starts, it does not have the permissions to run read/write to the device. First you have to kill the server, and then restart it as root:

sudo adb kill-server
sudo adb start-server

Then you can run this as any user:
adb devices
share|improve this answer
1  
You don't always have to run adb as root to start the server, but it's a lot faster when you're dealing with a lot of devices. –  Broam Sep 23 '11 at 14:17
add comment

When I've experienced that, I've had to kill adb and restart it with sudo. You might have to sudo the rest of your adb commands as well.

share|improve this answer
add comment

What number are you using for your udev? I wrote about my experiences with my HTC sensation here: http://colinwren.com/using-your-htc-sensation-to-debug-android-apps-on-ubuntu-11-04-natty-narwhal-using-udev-and-adb/

As stated by aspitzer use sudo to start the adb server. Also make sure you've got the correct device code. You can find this by using lsusb and looking at the code given here (use the first 4 characters)

share|improve this answer
    
(Note that referring to other answers as "above" or "below" isn't helpful as the answers can be sorted in numerous ways, not just chronological.) –  Al E. Sep 21 '11 at 15:16
    
+1 . I got caught there too when I assumed that the vendor id for my nexus s would be Samsung. In fact it's Google. The command is lsusb. –  daithib8 Sep 21 '11 at 23:35
    
amended answer for both of these. –  Colin Wren Sep 23 '11 at 8:29
    
Note that first is the vendor code and the second is the product code: the latter changes depending on the mode you are in. –  daithib8 Oct 5 '11 at 14:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.