Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I recently bought an Samsung S Galaxy II (i9100), and I am pretty pleased with it. It is by far the best phone I ever owned.

The only downside I have is that it has a really poor wifi signal. It gets almost half of the bars my old HTC HD2 got. This is not a big problem, I am not always far away from my router anyways.

The really annoying part is that is stops working after a few minutes. I am just browsing, and then suddenly the connection stops. I then need to switch off wifi, and back on the get the connection going again.

The signal is already on 'never sleep', so that is not the problem. And I do not have this problem with the HTC HD2, so it's not my router either, its just the phone.

Anyone know a fix for this, I have been looking on the net, a lot of people have this problem, but I failed in finding a good solution.

Really bad downside for such a great phone.

----- EDIT -------------

I also read an article about it maybe being the router. I downloaded a program called Wifi-Analizer. It said the channel had a poor signal, so I changed the wifi channel to 13. I also changed the settings to use N only, before it was B + G + N.

This helped a little bit at first, it does not break so often anymore, but the signal does break every few hours.

share|improve this question
1  
I face a similar problem with samsung galaxy S. I think after you root the phone, there is a way to replace the modem part of your phone. I will try after my warranty period. –  balki Jun 29 '11 at 9:57
    
Did you try your phone with another router? –  Pitto Jun 30 '11 at 7:59
    
@balki I just flashed my device with villainROM. It comes rooted, and you can replace the modem part. I flashed everything works great now. Maybe the problem was a bad modem. If you give an answer bellow I can give you the bounty points. As replacing the modem is the only option that worked for me. –  Saif Bechan Jul 4 '11 at 8:10

3 Answers 3

up vote 1 down vote accepted

Samsung modifed the modem component of android and it is buggy in galaxy S. The solution is to root the phone and replace the modem part of it.

share|improve this answer
1  
I think I have to give the points to this answer. Can you point me by the way to a good modem for the i9100. I use a good one now, but maybe there is a better one. –  Saif Bechan Jul 6 '11 at 12:46

this looks like a problem with your phone, because I know many S2 owners who have not had this problem. It is better you get the phone to your dealer and have it repaired or just try a factory reset, you might have installed an app that messed with the system files. All this is assuming your router is fine!

share|improve this answer
    
This could be right also. Unfortunately I had already flashed the rom a few times so my warranty is gone. When the problem persist I will use the USB jig to reset the warranty, and send it back to the store. For now all problems are gone with the new ROM and modem. Works faster and uses less battery also. –  Saif Bechan Jul 4 '11 at 8:22
    
if you changed your modem too there is no way to pinpoint at the source of the problem. Just for the sake of clarification try your old modem. –  Aadi Droid Jul 5 '11 at 5:28
    
I will try that today, do you have any good resource for the stock modem. –  Saif Bechan Jul 6 '11 at 12:47
    

I had the same problem on a home wifi network - I had the router configured to run 802.11b/g/n. The problem disappeared when I reconfigured the router to 802.11b/g only.

share|improve this answer
    
I tried everything with the router settings, I had no luck with it. I had the same problem also with other routers at friends. –  Saif Bechan Jul 4 '11 at 8:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.