Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

For the most part, I haven't had too many problems with the stock Email app on my Moto Droid. I have both ActiveSync (Exchange) and POP3 accounts set up and never have trouble with ActiveSync. But for some reason, with the POP3 account, sometimes the app gets into this endless loop and won't stop downloading the exact same message and showing it as unread.

I'll open the message, delete it, and then next time the app checks for new e-mail, the message is back again as if I'd never opened it in the first place.

Usually the problem seems to go away if I either (a) delete the message from the message list without opening it, or (b) delete it from within the message and then immediately hit "Load more messages". But neither of these methods work all the time; sometimes the message still comes back!

I'm wondering if anyone else has experienced this and knows why it happens (I assume it's got to be some connectivity issue - I do know that the Email app flakes out a lot due to 3G/WiFi switching, but that's hardly a complete explanation), and if there's any foolproof way to either ensure the message is deleted "for good" or to prevent the problem from ever happening in the first place.

Unfortunately I've never been able to reliably reproduce the issue - it seems to be random or at least intermittent.

Any ideas?

share|improve this question
    
My wife had the same problem accessing Hotmail through POP3 using the HTC Email app on the Desire. Tried everything and in the end I convinced her to get Gmail to pull her Hotmail email and use the Gmail app. Not exactly a solution but she is much happier now :) –  FoleyIsGood Nov 3 '10 at 19:34
add comment

3 Answers

I ABSOLUTELY HATE THIS ISSUE (sorry for caps but I have been dealing with it for a while). I don't have a fix but I do have work around: hit the show pictures button at the top of the message and let all images render before deleting. I wish I had a permanent fix for you. I wonder if this happens on other phones and not just the Moto Droid?

share|improve this answer
add comment

On my Motorola Droid, I was able to set up Hotmail as an Exchange Active Sync account. I followed the settings in http://windowsteamblog.com/windows_live/b/windowslive/archive/2010/08/30/hotmail-now-supports-push-email-calendar-and-contacts-with-exchange-activesync.aspx and everything worked fine. Now that I access Hotmail through ActiveSync, my email sync works great and deletes work too.

share|improve this answer
    
I don't understand how this is relevant to the question? I don't use Hotmail. –  Aaronaught Jan 19 '11 at 23:37
    
You didn't say who your POP3 provider was. I had the same symptoms when I used POP3 for hotmail. Switching to activesync fixed the POP3 hotmail problems I had. I was hoping this might help you. If it didn't, sorry. –  Michael Levy Jan 20 '11 at 15:20
add comment

Similar problems have happened with the stock email app on my Galaxy S. The app is super buggy and I recommend finding another app till it's improved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.