Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently, the Facebook app on my Droid 1 (Android 2.2.2) started prompting me to sign-in throughout the day. I get a pop up that says:

Facebook Sign-in Please re-enter your Facebook password

It shows my username and asks for my password.

It seems that if I don't use the phone for a few hours, when I pick it up, this sign-in is waiting for me.

Any ideas why? or what changed?

Update - not sure, but says

It seems like the mobile app doesn't play nice with HTTPS (secure browsing) if you have it enabled on the Facebook website. After disabling HTTPS on the full Facebook website under Account Settings, I was able to log in and stay logged in without an issue.

I don't want to give up secure browsing, but perhaps there was a bug in a recent udpate to the app?

share|improve this question
do you have any apps that are killing processes and clearing app data to free up space? – jlehenbauer Jun 28 '11 at 19:52
Are you using the very latest Facebook app from the Market? Have you tried clearing the cache and/or data? – Al E. Jun 28 '11 at 20:28
I can't check from here, but could there be a security setting at related to remote/mobile access that you recently changed? – Al E. Jun 28 '11 at 20:30
I have no apps running that automatically kill processes. (i have Advanced Task Killer free installed, but AutoKill is disabled. Yes, Facebook is up to date from the Market. – Michael Levy Jun 28 '11 at 21:04
Hmmm...I have my Facebook settings to "always use HTTPS" and I'm not seeing this behavior. Let me look in my settings again. – Al E. Jun 28 '11 at 22:24

I had issues with the last Facebook update, the one that came out the past 2 weeks. I uninstalled it and reinstalled it and now it works correctly. My issue wasn't quite the same as yours, it kept redirecting to the mobile website (although I do suspect some http vs. https issue), but I would give it a try. I know the advice seems weird because the update is like a new install, but it worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.