Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I receive a text message to my Google voice number, I get a notification from my text application, as well as the Google Voice application. It would seem that the message is being forwarded to my cell number, but I've turned off text forwarding in the Voicemail & Text settings. Is there another setting that I am missing?

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

From Google Voice settings (on the web, not the phone app), under phones, select your mobile number, and Edit. Uncheck "Receive SMS on this phone"

share|improve this answer
2  
This is a bad idea. It will solve your problem but it will also make it so that if the Google Voice app ever crashes or you are in an area without data coverage, you will not get your text messages. It is much better to leave this unchecked and then uncheck the "Notifications via text message" box in the Google Voice app on your phone. This ensures that you don't get double-notifications, but still get text messages if the Google Voice app can't connect. –  Rohan Singh Sep 13 '10 at 19:29
    
Didn't realize that. Voting your answer up, mine down. –  Paul Roub Sep 13 '10 at 19:48
    
Moto DROID v1 with latest GV. Notifications via text message is unchecked, phone is set as Receive Text Messages in GV web settings. This causes double-notification (triple if also getting e-mail notifications of new text messages). –  JadeMason Sep 13 '10 at 19:50
    
@JadeMason: In the Google Voice app settings, there's an area where you can select the phone number of the current phone. Is that set correctly? –  Rohan Singh Sep 13 '10 at 20:00
    
@Rohan: Yes, the number under 'This phone's number' appears correctly. –  JadeMason Sep 13 '10 at 20:04
show 1 more comment

Make sure you have updated to the latest version of the Google Voice application in the Market. Then open the app on your phone.

Go to: Settings > Sync and notifications. Uncheck the "Notifications via text message" box. Back all the way out, and just for good measure, reboot your phone.

share|improve this answer
    
After seeing JadeMason's comment on Paul Roub's answer I'm kind of unsure about this now. I know it works for me, but can't be sure it's the best way to do things. –  Rohan Singh Sep 13 '10 at 20:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.