Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a mac, and I have an apk file. When I connect the Tablet to the mac via USB, it does not show up in Finder. How can I get the apk transfered to the device?

I have installed Astro File Manager on the device, but that doesn't help me until I can get the apk file onto the device.

share|improve this question

migrated from Jun 29 '11 at 22:11

This question came from our site for professional and enthusiast programmers.

You still have to mount the storage medium within the OS. When you select USB mode after plugging in the cable, there should be a button offering to mount the internal SD card. Until the medium's mounted, there won't be anything for Finder to deal with. – Marc B Jun 29 '11 at 22:01

You can also use Dropbox to move a file onto the device. This will require minimal setup and provide an easy way to push future files to the Tab

share|improve this answer

The simplest way would be to use Bluetooth or to email the apk to your tablet. You can use adb as suggested by @Claire Swinson if your device is detected.

share|improve this answer
up vote 0 down vote accepted

Can you use adb to copy or install the apk file on the Samsung tablet? For example:

$ adb push my_app.apk /mnt/sdcard


$ adb install my_app.apk

I don't have a Galaxy tab so I don't know whether /mnt/sdcard is the correct location on that device.

EDIT: Oops. Forgot to say that when you connect your device via USB select the charge only option - don't mount the SD card!

share|improve this answer
@Claire I tried your suggestion but I get this in Terminal: -bash: adb: command not found – clua7 Jun 29 '11 at 18:36
@clua7 adb is in android-sdk-mac-x86/platform-tools. Its exact location will depend on where you installed the sdk on your mac (for me it's in my home directory). Either cd to the directory and then run adb or use a relative path, e.g ~/android-sdk-mac-x86/platform-tools/adb – Claire Swinson Jun 29 '11 at 18:46
@Claire thanks for trying to help. I copied the adb file to my builds directory (where the apk is located). I still get adb: command not found – clua7 Jun 29 '11 at 18:55
Tried this: ~/android-sdk-mac_x86/platform-tools/adb push myApp.apk /mnt/sdcard. I get this: * daemon not running. starting it now on port 5037 * * daemon started successfully * error: device not found – clua7 Jun 29 '11 at 18:59
@clua - that's probably because the current directory isn't in your PATH (echo $PATH to see it). From the directory where adb is type ./adb this should find it. – Claire Swinson Jun 29 '11 at 18:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.