Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an HTC wildfire. I am currently developing an application which I am consistently testing on my phone. Since yesterday for some reason I am not able to install any apk of that particular app that I am building.

The usual method of installation I use is download to SD card and then install from there. Other apps get installed with this process but not my app.

The error message - App not installed.

I am able to download and install my app from the market.

I have tried deleting all information from the phone regarding the app i.e cache etc but still doesnt work.

Not sure if the phone has blocked my app ? Can it do that ..?

share|improve this question
Have you tried uninstalling completely and re-installing? Can you try installing it from a computer using adb install -r [apk]? This will give you a more detailed failure reason. – eldarerathis Jul 7 '11 at 13:03
up vote 4 down vote accepted

I did an adb install -r [apk] thanks to the comment by @eldarerathis and I got an install_failed_container_error as the reason for installation failure...

Further searching got me to this link

The solution being a temp file inside .android_secure folder not getting removed. So once i deleted the file app installed properly. Thanks everyone for helping out!!

share|improve this answer
Awesome! Don't forget to "accept" this answer so it can act as a signpost for future readers. – Al E. Jul 7 '11 at 17:15
I will!! Though I have to wait for a couple of days – Slartibartfast Jul 7 '11 at 17:39
Sometimes I think that Google needs to make it more publicly known that adb install gives you a detailed error message instead of "Oops, didn't work!" like the GUI does. That's such a esoteric reason for the install to fail that I can't imagine how anyone would figure it out otherwise (I had never even heard of this error). Not to say that you didn't already know this - I'm not sure if you did - but plenty of questions on Stack Overflow can be diagnosed the same way and most people seem to have no idea. – eldarerathis Jul 7 '11 at 21:23

Go to Apps>Settings>Applications, there look for Unknown Sources that is first option. Make sure it is ticked.

share|improve this answer
Yes it is, I've been installing the apk without any problems for quite a while now. – Slartibartfast Jul 7 '11 at 11:13
there shouldnt be other ways your android should block the apk.. maybe its the app that's not properly developed – Power-Inside Jul 7 '11 at 13:22
Unfortunately even the previous versions which used to work fine aren't installing. Plus when I tried it on a different phone Samsung Galaxy I9000 it worked fine and there were no issues – Slartibartfast Jul 7 '11 at 14:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.