Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Problem description

I did factory reset of my phone, (Droid X), and I changed primary email, and I am not able to download any application from market. I get a message like application will be downloaded, but its never download app .

And I am using this same email id, as test account in developer account.

How can I download application from market? I am using wifi network.

share|improve this question
    
are you downloading from the website or from the phone app? have you tried both? –  santiagozky Jul 7 '11 at 13:07
    
Yes I tried both. –  Pankaj Kumar Jul 7 '11 at 13:59

1 Answer 1

up vote 4 down vote accepted

Try clearing the data for the Market app:

  1. Go to Settings -> Applications -> Manage applications -> All and find the Market app
  2. If it's running, kill it with the button there
  3. Clear the data (this will clear the cache as well, no need to do both manually)
  4. Restart your phone

Then try the Market again.

Edit: Since that didn't work, I would try wiping the data partition (similar to a factory reset):

  1. Power off your phone
  2. Boot into bootloader mode by holding down Volume Down, Power, and the Camera button.
  3. Pull the battery and power back on while holding the Home button. Once you see an Android with the triangle & exclamation point, press the Search button.
  4. Using the side volume buttons to move around and the Power button to select, select the "Wipe Data" option.
  5. Once the wipe is finished, select "Reboot system now".
share|improve this answer
    
I did it, but problem is same. –  Pankaj Kumar Jul 8 '11 at 5:06
    
@pankaj Hmm. I would try wiping the data partition at this point, I've updated my answer. –  Matthew Read Jul 8 '11 at 14:35
    
Now I am unable to start my phone. When I pulled the battery, phone went to off and till then I am not able start my phone. Please help me. –  Pankaj Kumar Jul 11 '11 at 5:52
    
@pankaj That's very strange, pulling the battery while it's sitting at the bootloader shouldn't have hurt anything. Try a few more battery pulls and holding various keys while you power on, and try with and without USB plugged in (make sure the phone is charged as well). If that doesn't work, from what I understand you need to use RSDlite to re-flash your ROM. Instructions are here, though I haven't tested them myself ... use your judgement. Good luck! –  Matthew Read Jul 11 '11 at 14:43
    
thank you very much –  Pankaj Kumar Jul 14 '11 at 5:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.