Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I connect my Xoom to my PC via USB cable I get a Xoom "Portable Media Player" showing up in my Windows Explorer. When I browse the drive, I can only see half the folders compared to if I browse the SD card directly from within Astro file manager on the Xoom.

Why aren't all files and folders showing up? In Android (3.2), I've tried copying a file from a "hidden" folder to a folder that I can actually see on the PC but the file does not show up.

Someone suggested it was because it didn't get mounted as "USB Mass Storage".

How can I copy the files?

(same functionality works fine from my HTC Desire)

share|improve this question
Are the missing files actually on the external SD card, or are they in the Xoom's internal /sdcard directory? – eldarerathis Jul 16 '11 at 22:47
I have not installed any external SD card, so I assume it's the internal memory. The files can be seen in /sdcard subdirectory (as well as /mnt/sdcard). However, not all files seen there are visible in my PC – AtliB Jul 17 '11 at 9:52
Do those hidden folders start with a dot "."? Have you tried enabling options in windows explorer to show hidden files? – Audrius Jul 25 '11 at 12:16
@Audrius Windows doesn't hide folders starting with a dot, they have to be marked as hidden in their properties. – onik Jul 27 '11 at 9:53
Does Windows Explorer show it with a phone or PMP icon instead of a drive icon? If so I would suspect onik's answer is correct. – Matthew Read Jul 28 '11 at 13:52
up vote 0 down vote accepted

Try WiFi File Explorer (also available in pro version with more features). It reads your SD card just like Astro does, allows you to view it from a computer browser, and does not require root. You may be able to view your files from here, and if so, you can download them via WiFi network.

Let us know if it works! :)

share|improve this answer
Unfortunately I don't have a WiFi connection at home! – AtliB Aug 19 '11 at 11:44
ouch :/ let Mr know if you get one then! :) – jlehenbauer Aug 19 '11 at 14:18

you may try install the android SDK and use adb-pull under command-line.

share|improve this answer
Sounds like bit of an overkill :) – AtliB Aug 19 '11 at 11:45

Simple painless can be with Dropbox application where you can share files between various platforms. No need for cable just wireless access ;)

share|improve this answer

Apparently Android versions 3.1+ support MTP for file transfers. This is a better protocol than USB Mass Storage for media files (music, photos, videos) but won't necessarily work with all files as well. Probably since this mode is meant for media transfer, the system and data folders are hidden from the user.

share|improve this answer
Strange, since the files that I'm not able to access are in fact images! – AtliB Aug 19 '11 at 11:44
Got a Samsung Galaxy Tab a couple of days ago and it uses MTP, but I can see all the same folders on it. So I don't think it's a MTP problem anymore. At least not a general Android-MTP problem, don't know if Motorola or Samsung use modified protocol stacks. – onik Aug 19 '11 at 17:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.