Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I suspect that there isn't a way to do this, but just in case...

Is there any way to disable Priority Inbox on the Android Gmail application?

I don't use this feature and can disable it in the web based full desktop client(*), but I can't disable this on either the Android Gmail application or the mobile web Gmail client, it's very annoying.

  • Gmail version v2.3.4.2
  • Samsung/Google Nexus S
  • UK / Three network

Not for the first time I find myself wanting "Minimalist for Gmail™" for Android!

edit * after further investigation it would appear that my desktop inbox is set to classic, but I can still see priority inbox esque things in my messages like "Important mainly because of the words in the message." in the details of my messages. It may be that my Priority Inbox is only half-turned off, if that is even possible?

I have removed a (second) work Google Apps account so I only have my personal email account on my phone and I have disabled IMAP on my Gmail account.

share|improve this question
    
I'm confused, I don't use Priority Inbox on the web version, and I don't see priority inbox in the Android app? Didn't think it was possible on the app if it's switched off on the web? –  GAThrawn Jul 24 '11 at 10:44
    
I must just be lucky... it's turned off in the full web version (as opposed to the mobile web version) but it appears in both the mobile web version and the app-on-phone version with no way of turning it off. –  Richard Jul 26 '11 at 12:38
    
Just to be complete, can you please add the device you're using and your carrier to your question? –  Al E. Aug 2 '11 at 12:30
    
I think its a recent thing on the android app... I don't have priority inbox on the web - in fact the first I'd heard of it was when I got this tablet and it appeared on the list. There is no option to switch it off that I can see - only an option to make it default which is ghd opposite of what I want to do Seems to me to be a wholly useless feature - especially as spammers have already worked out how to mark their email as 'priority' Gmail 3.2-150265 (latest) –  user7291 Aug 14 '11 at 13:25
add comment

3 Answers 3

Menu button -> More -> Settings -> Priority Inbox. I have it enabled on the web and that option unchecked to disable it in the app. Latest Gmail v2.3.4.1.

share|improve this answer
    
I don't have that option on my Gmail application on my phone unfortunately, I have an option to make the Priority Inbox my inbox which doesn't help. I'm on the most recent version of Gmail on my Nexus S that the application store has offered to me, I don't know how to determine the version number of the Gmail app unfortunately. –  Richard Jul 26 '11 at 12:37
    
@Richard You can check the version via Settings -> Applications -> Manage applications. –  Matthew Read Jul 26 '11 at 14:12
    
Thanks for the tip, I'm running v2.3.4.2. –  Richard Aug 1 '11 at 10:34
    
@Richard I've since got that update and I now see the option at Menu -> More -> Settings -> username@gmail.com -> Priority Inbox. You can also check Sync inboxes and labels to make sure all mail is being synced. –  Matthew Read Aug 2 '11 at 2:24
    
Thanks again Matthew, the menu sequence is slightly different on my phone, I don't have the extra accountname@gmail.com step to get to the Priority Inbox checkbox (and the description of this checkbox on my phone is that this is to set the default inbox to the priority inbox, rather than to turn it off?). I've tried two other things, I have removed a work Google Apps account so I only have my personal email account and I have disabled IMAP on my Gmail account. Neither seem to have helped, bah. –  Richard Aug 2 '11 at 8:37
add comment

I found that by opening the local Gmail app and navigating MENU > MORE > SETTINGS > USERNAME@GMAIL.COM > (Uncheck "Make Priority Inbox your default inbox...") and click on "Sync inboxes and labels" and change the option for "Priority Inbox" to "Sync None".

This seems to work for me. However, I just tested it once and I didn't get the Priority notification so I hope this will help you.

share|improve this answer
add comment

All you need to do is...

  • Open the gmail app
  • Go to Settings
  • If you have multiple accounts, click the specific account for which you want change it
  • Make sure the Priority inbox check box is unchecked.
  • In the same page under the data usage look for a 3rd option Manage labels and click that

  • Click the 2nd option you ll find " Priority Inbox" option click on that and uncheck all the options there.... Now all the features under the priority inbox option will be disabled.....

This absolutely worked for me.....

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.