Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm currently running CyanogenMod 7.0.3 on my HTC Desire, and pictures copied to the SD card disappear!

If I copy an image from my computer to the phone using USB Mass Storage mode, it disappears as soon as the copy is finished.

Pictures taken with the Camera app disappear too.

Pictures copied with adb push some_pic.jpg /mnt/sdcard/DCIM/100MEDIA don't show up in the Gallery app.

share|improve this question
    
Do they show up if you check with a file explorer (and are just missing in the gallery)? In this case, it might be a .nomedia file in the very same directory (or a level up), see android.stackexchange.com/questions/27714/… –  Izzy Aug 16 '12 at 12:43
    
I can see them with a file explorer, they're just missing in the Gallery. I've searched for .nomedia files using find and found one in the card's root, but I suspect it's been recently added by a recent ROM Manager bug (I didn't take note of the file's creation date before deleting it). –  Daniel Serodio Aug 16 '12 at 14:45
    
I've removed /mnt/sdcard/.nomedia and /mnt/sdcard/DCIM/.thumbnails and rebooted the phone, and the pictures are back in Gallery. Let's see for how long... –  Daniel Serodio Aug 16 '12 at 14:59
    
For as long as you keep that .nomediafile away :) I added this as an answer, including some closer explanation -- so you might want to check and possibly even accept it, as it solved your issue. –  Izzy Aug 16 '12 at 15:33
add comment

3 Answers 3

I noticed a similar problem on my HTC G2 recently after I migrated phones. Deleting the thumbnails folder fixed the problem.

See also: Not all images showing up in gallery

share|improve this answer
add comment

Check you SD card for errors, preferably by powering down the phone, removing it and inserting into an SD reader.

And always use "Safely Disconnect Hardware" in Windows system tray or unmount the USB mass storage device in Linux.

share|improve this answer
add comment

A quite common cause for "disappearing media" is not restricted to photos only, but can also affect audio and video files:

The media scanner checks each directory for a file named .nomedia (this file can be empty, its content is not checked). If found, this directory including its subdirectories is skipped from scan -- which means, this media does not appear in the gallery.

You can easily check if this might be the cause:

  • use a file explorer (e.g. ES File Explorer) to check whether your media is where it should be (i.e. usually somewhere on your sd card). You can also check this from your computer via USB.
  • if so, check all the tree along for a file named .nomedia (note the leading dot!). It may reside even in the root directory of your sd card -- or somewhere in the path to your media files
  • if found, just delete it (safe to do so -- you can re-create it anytime, it has no important content but is more likely even completely empty).
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.