Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just conducted a tiny experiment with the original headset that comes with Nexus One: I plugged it into the phone, expecting the phone built-in microphones to be switched off, replaced by the microphone on the headset.

I was disappointed to see that the voice input behavior of the system didn't change: The phone seems to continue picking up sound from the built-in microphone(s).

So, I thoroughly covered the headset's microphone with tape and tried again...

Still, no change. The Nexus One's built-in microphone are fully enabled.

This is disappointing because I really need to disable the Nexus One's built-in mics, so that I can use a different microphone instead.

Is there a way to accomplish that?

share|improve this question
    
which icon do you see in the notification bar, headphones or headset? –  devnul3 Sep 19 '11 at 20:44
add comment

1 Answer

up vote 1 down vote accepted

Maybe disabling the noise cancellation feature might work..

Get a rooted file editor first, then from "/system/build.prop" change the "media.a1026.enableA1026=1" to "media.a1026.enableA1026=0"

Then do a reboot. See if your problem is solved. I simply suspect the android's mic always gets enabled for the purpose of noise cancellation during calls/voice input.

REMEMBER! I do not hold responsiblilty for any failure. I suggest you make a backup and everything when you try this.

SOURCE: http://forum.xda-developers.com/showthread.php?p=6787214

share|improve this answer
    
You are the only one who answered, so accepting. –  Android Eve Aug 19 '12 at 19:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.