Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I recently bought a Samsung GT i5800, ok. It has Android 2.1 update1 installed. ok.

If i need to connect to the internet through wifi, then i can, ok!

If i need to connect through a vodafone mobile internet connection, then i just can't!! What could the problem be? I tried to reset the phone to factory settings, and then power off, power on, then enter PIN, then? it should work, no? Why does it say's "the page cannot be displayed"? why isn't working?:O

Are there any tips? Can i provide you guys with more info? [what info?]

this is getting urgent, and i spent all the dawn with this problem.

There is an icon at the top displaying that it has enough signal strenght, but it doesn't displays an icon @the top that says it's connected through 2g, or 3g.

:( please help!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Check that the following setting is ticked:

Settings->Wireless & networks->Mobile networks->Data enabled

Also verify that the access point name settings are correct and the correct access point is chosen. You should be able to find the details of what it should be on the Vodafone website. The settings are at:

Settings->Wireless & networks->Mobile networks->Access Point Names

share|improve this answer
    
THANKS!!! the APN was missing, it didn't create it automatically, I had to do it manually! Thank you! –  LanceBaynes Aug 10 '11 at 3:39
    
@LanceBaynes Kindly keep the profanity and caps to a minimum :P –  Matthew Read Aug 10 '11 at 3:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.