Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

A while back I put a Gingerbread [Deck] rom on my HTC EVO, and it came with another camera app (apparently the one that ships with the new Nexus S). While it does have some fun little features, I don't like it nearly as much as my original one, the main feature being spot focus on a touch to the screen. I have checked out third party camera apps, but none have quite done it for me. Does anyone know how I can get my stock camera app back?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The most accessible way to get a copy of the app itself would probably be to download a stock ROM in zip format and just extract the HTC Camera app (/system/app/HTCCamera.apk). A de-odexed version would probably be easiest, but in theory you could extract both the .apk and the .odex file and put them on your device if you wanted.

To be honest, though, I'd be pretty skeptical about the HTC Camera working on your ROM since Deck isn't Sense-based. You can give it a shot, but I'd wager it relies on some Sense framework files (never tried it myself).

share|improve this answer
    
yeah, same as above. it allows me to "upgrade" when i try to install the .apk, but then it gives me a checkmark and says "application not installed" :/ –  jlehenbauer Aug 23 '11 at 21:42

Did you take a Nandroid backup or a Titanium backup before flashing? If you have a Titanium backup, you can try restoring the Camera app from there (app only, data can be incompatible). If you didn't backup with Titanium, you could do a new Nandroid backup, restore to the previous one, create the Titanium backup and then restore the new Nandroid backup. After this restore the app from the Titanium backup.

Since this is a system app I can't guarantee the compatibility of the app, but you can try and if it fails/is buggy, you can revert with Nandroid.

share|improve this answer
    
almost worked. i got the app on but like you said, there are some dependencies i think. it installed the app, but it simply crashes each time you try to open it :/ –  jlehenbauer Aug 23 '11 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.