Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have 2 Google calendars, associated with my account. But after synchronisation, android shows only one (the first).
I've review Google calendar settings and found, that only the first has field "Owner", filled with my account. The second is seemed to be shared and I am not owner, but simple member.
How can I make my android (Samsung Galaxy Tab) synchronize with both calendars?

share|improve this question
add comment

4 Answers

up vote 5 down vote accepted

I recall having this issue with some calendar not showing up. If I remember correctly it had to do with having some calendar disabled/hidden in google calendar at the time of the first sync; the calendar app would then not bother looking for other calendars.

Try going in Settings > Accounts and Sync > Auto-sync and uncheck it.

Go to google calendar on the web, make sure all your calendar are visible.

Then in Settings > Applications > Manage Applications > All > Calendar Storage > Clear Data

Back to Settings > Accounts and Sync > Auto-sync , check it.

When you next open your calendar, it should be empty, but you should be able to select all your calendars.

share|improve this answer
add comment

I have multiple calendars syncing to my Droid, only some of which am I the owner.

Go to the Calendar app, and press Menu | More | Calendars. Make sure that both calendars under your account are set to "synced, visible". If not, tap until it changes to that setting.

share|improve this answer
1  
In Menu|More|Calendars I see only 1 Google calendar, but I have 2. –  Sergey Metlov Aug 27 '11 at 8:01
add comment

If you are using multiple Google accounts, you need to make sure that all of them are set to sync calendar data:

  1. From the home screen, go to Menu -> Settings -> Accounts & sync
  2. Tap on your Google account.
  3. Ensure the "Sync Calendar" option is checked.
  4. Repeat steps 1 - 3 for every Google account you've added.

Samsung has their own Calendar app on the Galaxy Tab, which is slightly different from stock Android:

  1. Open up the Calendar app.
  2. Tap the Menu button, go to Settings -> Calendars.
  3. Make sure the calendar you wish is checked (you can also select the "All calendars" option on top.)

Your second calendar should now properly show up in all apps that poll calendar data.

share|improve this answer
    
I have only 1 account with 2 calendars. Unfortunately, I see only 1 Google calendar in settings. –  Sergey Metlov Aug 27 '11 at 8:02
add comment

Today I tried Calsync to sync Lotus Notes calendar to Android.
It worked and I was able to sync the lotus notes calendar to my Google account where I have multiple calendars. I found that my phone (HTC Desire HD) is by default able to select and sync multiple calendars but my galaxy tab 7" is not able to.


I have found a way to activate multiple calendars in Samsung Galaxy Tab:

  1. Download the aCalendar app from Google Play Store (This is a free app).

  2. Run it and it will open the calendars that was synced by the Galaxy Tab (which is by default the main calendar in your Google account).

  3. In the "Setting" or in "More Options" of aCalendar you have an option to select other calendars set-up in your Gmail account (It will display all calendars in your Gmail account).
    After selecting multiple calendars also it does not sync by default. You will find that the additional calendars are selected in a light color not the normal dark colour for sync.

  4. Now touch and hold the calendars that you want to sync and it will popup with a message to sync. Sync and then that calendar will get synced not only in aCalendar app but also on the Galaxy Tab default calendar.

Hope this helps people who cannot sync multiple calendars with Samsung Galaxy Tab!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.