Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi guys i've been trying for quite a while to unlock the bootloader of the phone i've bought. It's from hong kong and branded to vodafone it's not sim locked as I tried an optus sim and it worked.

I press and hold the search button and plug the usb in and I get a blue light but when I try to check if fastboot can find it, it can't.

Any ideas what the problem is?

share|improve this question

migrated from Aug 29 '11 at 13:25

This question came from our site for professional and enthusiast programmers.

up vote 1 down vote accepted

If fastboot from your computer can't find it, try following these steps exactly, beginning with installing the Requirements below. The most likely problem is some sort of driver missing, disallowing the computer from reading the phone in while it's in the bootloader.

This guide can be found on, and uses a fastboot program from your computer to unlock the bootloader:



  1. To begin, navigate to this website:
  2. Click Continue at the bottom of the page and enter your device’s IMEI code, name and email address in the relevant fields.
  3. Your unique unlock key will now be mailed to you.
  4. Now unzip fastboot.rar and open the folder extracted.
  5. Within that folder, hold the Shift key and press the right Mouse button. Now select Open command window here.
  6. Now we need to connect the phone to the pc in fastboot mode. Do so by turning the phone off, holding the menu button (search button for the Xperia Play) and plugging in the USB Cable.
  7. Now in the command prompt, enter the following command:

fastboot.exe -i 0x0fce getvar version

  1. Now enter the command, replacing KEY in the string with the unlock key mailed to you:

fastboot.exe -i 0x0fce oem unlock 0xKEY

That is it! The bootloader is now unlocked.

share|improve this answer
I fixed it :) I just had to update the original firmware. Then do those steps. That seemed to fix it. – Josip Gòdly Zirdum Aug 30 '11 at 13:24
cool! glad you found out how to fix it :) – jlehenbauer Aug 30 '11 at 14:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.