Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Is it possible to access (programatically, using a text editor, etc.) each dictionary of the built in languages in Android?

The automatic word completion is really useful but it has a major problem when it comes to SMS messaging. I'm Hungarian and our alphabet contains special letters like 'á', 'ő', 'ú' and so on. As you can see each basic letter has a single or a double accent on the top of it (or a dot). If that accent leans to the right like this: 'á' then only 70 letters are allowed to send in a single SMS message. There is another version of that letter in Android when the accent leans to the left: 'à'. Using this will not reduce the 160 letters to 70.

Unfortunately all the built in Hungarian words use the wrong version of those letters so I have two options when composing a new SMS message:

  1. Turn off word completion and use the basic letters like 'a', 'o', 'u'.
  2. Use word completion but correct the wrong letters. This takes at least twice as much time to complete a text message.

So I'm wondering if it would possible to rewrite the dictionary of a language in any way?

share|improve this question

migrated from stackoverflow.com Aug 31 '11 at 14:57

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Have you tried using a different onscreen keyboard? There are several on the market like SwiftkeyX that use their own autocompletes, and they have other languages available.

share|improve this answer

I was having the same issue but in Spanish and i just disabled sms division on the messages option menu and problem solved, no need to hack around dictionaries

EDIT:

Go to "Messages" > Press "Menu" key > Press "Adjustments" (in spanish it says "Ajustes") > Uncheck "SMS Split"

BTW, this question is more suited for the android.stackoverflow.com site.

share|improve this answer
    
Can you please tell me the exact steps you performed? Thanks! –  papaiatis Aug 31 '11 at 7:12
    
What Android version do you use? I don't have the "Adjustments" menu item neither the "Uncheck SMS Split" anywhere... –  papaiatis Aug 31 '11 at 21:29
    
I have Gingerbread 2.3.4 maybe that option was disabled on previous versions –  Chiguireitor Sep 1 '11 at 13:42
    
Maybe it's a feature of 2.3.4. I'm using 2.3.3 and unfortunately I don't have that option. –  papaiatis Sep 1 '11 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.