Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy S2 (running Gingerbread 2.3.3) and enabled syncing of contacts for Facebook, Twitter, LinkedIn and Google. I've been finding it really annoying that when I go to write a message I start typing in a name and I get a bunch of e-mail addresses from Facebook, etc - people who are not in my main contact book and that I do not want to contact from 'Messaging' on my phone.

I have tried setting the option where only contacts with phone numbers are displayed but I think this only applies to the 'Contacts' application and not messaging. Any ideas?

share|improve this question

2 Answers 2

If you're using the in-built (stock) messaging app, see if there's an option in the settings similar to what you've described. By default, only contacts with mobile numbers should be shown.

Alternative messaging apps like GoSMS and Handcent also have an option to restrict contacts with mobile numbers. In GoSMS, it's in the SENDING section of the settings.

share|improve this answer
    
I've had a look at the Settings for the 'Messaging' app (yes, I'm using the in-built standard app) and there doesn't appear to be a similar setting. –  Andrew Humphries Sep 2 '11 at 22:28
    
It's there in Android Eclair. Perhaps it was removed in Gingerbread. Like I mentioned earlier, I strongly recommend switching to an alternative SMS app for the sheer range of configurable options available. –  Sparx Sep 3 '11 at 14:15
    
Do you have any recommendations for SMS app? I don't know if the fact that I'm in the UK matters at all. –  Andrew Humphries Sep 3 '11 at 19:45
1  
GoSMS and Handcent SMS are both free and have loads of features. Both are regularly updated. Do remember to disable notifications in the stock Messaging app if you use an alternative app- this will avoid duplicate notifications. –  Sparx Sep 4 '11 at 17:30

I had similar problems. Finally I just decided to unlink all my contacts from both Gmail and Facebook and whatever else, Android want's to sync contacts with. Basically turn off any contact sync you may find on the phone. Then backup and clean out or delete the entire Address book. (Do the same with "new" phone contacts in Gmail, which usually gets doubled.)

Here is a long guide how to manually backing up all your contacts and emails to a CSV file, and how to import them again. You can then use the same CSV file to import your contacts into Gmail afterwards.

"About Contacts Import/Export, Backup/Restore and Data/Sync"

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.