Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a few WiFi network in the neighborhood and the Nexus S will always detect those networks that I never use. However, for my own WiFi network, it randomly fails to recognize the network, even though I sit right next to the router. I know that everything else is OK, because I can access the network through my laptop, and if I just restart the router, the phone will start to pick up the signal again.

I think there might be something wrong with my router, because I never have that problem with the network at work. The only difference I can think of is, I turn off my router right when I stop using WiFi...

What might be wrong? Is this a known bug? Are there workarounds (that does not involve restarting the router?

Update: I do find some clue. If I turn the router on before turning on wireless on the phone (via the power management widget), then things work just fine. If I turn on wireless on the phone before the router, I'll need to restart the router. I don't know how much sense it makes though.

share|improve this question
    
Was this always the case? This really sounds like your router is just flaky, which we can't help you with ... –  Matthew Read Sep 2 '11 at 18:15
    
No it's random. And if the problem is with the router, then why don't I have it on my laptop? –  phunehehe Sep 3 '11 at 17:17
add comment

1 Answer 1

up vote 2 down vote accepted

I've found the problem. Both the router and the phone was working correctly. The problem is with the Wifi channels. According to Wikipedia's List of WLAN channels, some places only allow channels 1-11, some others 1-13. Devices will provide support accordingly. My router supports channels 1-13, while the phone (I guess) supports channels 1-11. So when the router uses channels 12 or 13, the phone cannot detect the network!

Solution?

  • Buy another router which only support channels 1-11.
  • Logon to your Routers config through your browser to find whether the router supports limiting the channels. Refer to your Routers user manual on how to do this
  • Change the channel settings on the router to be manual (i.e not automatic), and somewhere in the range 1-11 (preferably 1 or 6 or 11).
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.