Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed HTC's official (developer-only) Gingerbread ROM on my HTC Desire, but I'm not too happy with it, since it keeps running out of internal memory. So I've been searching for a way to revert back to the original FroYo firmware, but I couldn't find it.

Also, I tried to root my phone so I could install CyanogenMod, but that didn't work: apparently, my firmware is too new.

So, what's the best way to revert back to official FroYo? Or, failing that, to root my phone?

UPDATE with some context: I never rooted, or tried to root, my phone before this failed attempt, and I only did it because I couldn't find an official means to go back to FroYo. I tried both and Unrevoked. The latter complained that my firmware is too new; the former just got stuck while "waiting for fastboot".

UPDATE 2 I just tried to install a RUU, but it complains about the boot loader being too new. So no help there, either.

share|improve this question

The best known option for the HTC Desire is to use unrEVOked -

unrEVOked has the added benefit of flashing in a version of Clockwork Recovery. That way you can just boot into recovery, do data wipes, and flash Cyanogenmod.

Note that there is a chance that Gingerbread could prevent unrEVOked from performing its usual processes. In addition, your previous rooting adventures could have placed an alternate recovery into the phone as well. I believe you can press Power+Vol-Up when starting the phone to invoke recovery mode. If Clockwork is present, you may proceed to flash away.

share|improve this answer
Unrevoked was the one complaining about the firmware being too high. just didn't do anything at al... so no dice. Also, I never tried to root my phone before this failed attempt... – jqno Sep 8 '11 at 5:59
up vote 1 down vote accepted

I was able to root my phone using after all, following the steps described here. However, instead of running ./revolutionary as described on the page, I had to use sudo ./revolutionary to make things work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.