Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My D2G updated to 2.3 today, and I'm no longer able to tether.

Prevously, I had no problem using Wireless Tether 2.0.7 with Android 2.2.

Now that I'm on 2.3:

  • Wireless Tether 2.0.7 will start up and I'm able to connect my laptop to its WiFi network, but Verizon redirects me to the self-provisioning page; I have no internet access.
  • Wireless Tether 3.1-beta6 doesn't work. It says tethering is enabled, but the WiFi network does not show up on any other devices.

How can I fix this?


Edit: This appears to be a reported issue.

share|improve this question
    
are you running a custom rom, or just a rooted version of the stock one? –  jlehenbauer Sep 8 '11 at 6:01
    
@jlehenbauer: Rooted stock. –  josh3736 Sep 8 '11 at 14:09
    
hmm. this same kind of thing happened to mine, but it ended up being that the ROM i was using (not stock) had this functionality built in, and the wifi-tether app interfered. but obviously, this doesn't quite fit your problem. sorry :/ –  jlehenbauer Sep 12 '11 at 19:44
add comment

3 Answers 3

up vote 2 down vote accepted

I was able to solve this, but it's not pretty. Following the advice in this thread, I applied a hack to the radio that gets Wireless Tether working.


Edit: I can confirm this exact procedure will also work on a Droid X.


  1. Download and install RadioComm. It worked fine on Windows 7 x64.
  2. Open Radiocom. This was the first time I opened the app, and a splash screen asked for me to "select which MA to use." I couldn't find the MA mentioned in the thread in this list, so I just selected 3G All Others (or something like that).
  3. Open the Main menu, select MA, Common, MDM 6x00 Chipset Base.
  4. Open the Settings menu, select USB, PST USB Driver.
  5. Connect phone to computer via USB. Change the phone's USB connection mode to PC Mode.
  6. The Radio Detection icon on the right side of RadioComm will turn green.
  7. Scroll to the P2K 4 tab.
  8. In the STELEM / RDELEM section, tick the Dec Entries radio box.
  9. In the text boxes, enter:

    Element ID: 8040
    Record #:   1
    Offset:     0
    Length:     128
    

    Press RDELEM. It will turn green and the following data should appear:

    40767A7733672E636F6D00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
    
  10. Change Element ID to 8041.

  11. Press STELEM. It will turn green.
  12. Change Element ID to 8091.
  13. Press STELEM.
  14. Change the phone's USB connection mode to Charge Only.
  15. Reboot the phone.
  16. Install Wifi Tether 3.1-beta6.
  17. In Wifi Tether's settings, change the Device Profile to Motorola DroidX (CDMA). (Droid2 does not work.) This is a good time to set your SSID and encryption as well.
  18. Done. You can now tether.

In case you need to revert the changes we just made, here's the original values: (these are the same on a D2G and Droid X)

8041:

4064756E2E767A7733672E636F6D000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000

8091:

40767A7733672E636F6D00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
share|improve this answer
1  
I guess I had the WiFi Tether still running in the background so I had to do this twice. For others who already have WiFi Tether 3.1-beta6 loaded, reboot your phone first then follow josh3736's instructions. Worked great on my Verizon Droid 2 Global after the 2.3.3 OTA update. –  user8097 Sep 18 '11 at 15:47
    
Since the 4.5.605 update to Droid X, this seems to be doing the trick so far (10 minutes in). Thanks for the hack! josh3736 FTW –  user8356 Sep 29 '11 at 3:52
    
This is awesome. Worked great! –  Ryan Farley Jan 9 '12 at 23:31
add comment

We have here two situations colliding. For Wireless-Tether to have worked in the first place, it means that you were rooted.

It is typical behavior of OTA updates to remove root access. You must re-root your device in order to ensure that Wireless-Tether will work properly again.

The root access portion of Wireless-Tether is what helps it work its magic that prevents that Verizon hijack page from coming up.

share|improve this answer
    
Yes, I was rooted. Before the update, I manually unrooted (z4root) to ensure the update went smoothly, and after the update, I re-rooted with the Droid 3 one-click root. I am rooted properly (Titanium Backup works). –  josh3736 Sep 8 '11 at 2:36
add comment

The Droid X has a similar issue with this, make sure that you set the device profile to Droid 2 in wifi tether. This is a setting that was added in the Wifi tether 3.0+ versions.

share|improve this answer
    
Setting the device profile has no effect. –  josh3736 Sep 9 '11 at 19:22
add comment

protected by Community Oct 3 '11 at 15:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.