Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I plugged my phone into my TV's USB port hoping to play video from my phone on the TV. This was not successful. It's been about 4 days since I disconnected from the TV and it still thinks it's connected.

I have turned the phone off and on, it may go away for a little while but keeps coming back. The top left status bar will have 2 arrows spinning in a cirle and when I drag downwards to see my notifications I see this:

MTP service status:

Connected to computer

Any ideas?

My phone is an HTC Incredible 2 running Android 2.3.3.

share|improve this question
2  
I would give a check under Manage Applications and running services. See if there's an "MTP Service" or HTC media sync or something like that running, find it, and hit "clear data" and then force stop. But obviously, if there's no such service, this wouldn't be a very good answer! –  DavidAP Sep 19 '11 at 20:51
    
@DavidAP When I go there I see something called Accounts & sync and it has the same icon as the spinning arrows I am seeing in the status bar. However when I open it Clear data and Force stop are both disabled. The only option enabled is Move to SD card. –  JD Isaacks Sep 20 '11 at 15:18
    
@DavidAP - I followed your advice and it worked! I went to Settings-->Applications-->Manage Applications-->Running (tab on top,far-left). Scrolled until I found the 'MTP Service', selected it and chose the 'Stop' button. It will present a alert box, but just say ok. I have not seen it re-appear (yet). I will repost if it does. –  user17436 Jul 26 '12 at 19:13

3 Answers 3

I solved this by plugging in my phone to a computer and choosing Charge Only. It was using CPU and draining my battery until I fixed it.

share|improve this answer

As a worst case solution, you could try factory resetting your phone. You might also attempt to connect your phone to a PC and enable USB transfer, then eject your phone to see if this clears the issue.

share|improve this answer

When you say you turned your phone off and on, did you actually shut it down (hold down power button to get the menu), or just press the power button to turn the screen off? I would expect a shutdown and restart to clear this problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.