Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Whenever I connect my S2 to the power outlet (not to a computer), the Kies application pops up. Where do I disable this auto-activation?

share|improve this question
2  
Samsung Kies is one of the worst pieces of software I think I've ever come across. I had to install it to upgrade my mother's SGS, I was astonished by how much it clogged up my system (3 separate autorun entries, 2 services), and how unbearably slow it was. –  fredley Sep 20 '11 at 13:30
1  
@fredley Kies Mini is a lot better, just a small standalone app. –  Matthew Read Sep 20 '11 at 15:48
    
@Matthew Thanks for the advice! –  fredley Sep 20 '11 at 20:28
add comment

3 Answers 3

up vote 4 down vote accepted

Go to Settings > Applications > Development > and check USB debugging

After that if you connect your S2 to a PC it will connect in USB mode and you won't get the KIES application popup.

share|improve this answer
add comment

Sounds like there's something funny with either your USB cable, the charger or the socket on your phone that's causing it to detect it as a full PC connection, rather than just a dumb charger.

You should be able to get rid of that prompt for the moment by going into Settings -> Wireless and Network -> USB Settings and selecting the Mass Storage mode rather than the Samsung Kies mode.

However you really ought to try with another charger and cable to see if that fixes the actual problem, pure-charger cables shouldn't be detected as a PC, the signal on the cable is different and the phone should detect that.

share|improve this answer
    
I don't have USB Settings under Wireless and Network. –  ripper234 Sep 20 '11 at 22:24
    
@ripper sorry you must be running a different update then, I know Samsung have moved that setting around at times. Have a look under the other headings in Settings to see if you can see the USB settings, I think it might have been under the SD Card and phone settings in the past too? –  GAThrawn Sep 21 '11 at 5:54
    
haven't found it. –  ripper234 Sep 21 '11 at 11:32
add comment

They seem to have removed this option completely for S4 Active. One keeps wondering why Samsung chose to use Kies, which slows down file transfer substantially and, moreover, may do weird things like changing the photo date of image files when moved across the device's folders...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.