Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my totally stock Bell Samsung Galaxy S2 I have my main GMail account synced to it, it is also synced to my iPod using Exchange ActiveSync.

My phone's default calendar has all the events from my Google Calendar that I had been organizing and creating events from my iPod calendar with. However, when I create a new event I get this error. I tried going to the Account and Sync settings, then syncing the calendar, but the wheel stops spinning after a little bit, then just disappears and the problem remains.

I tried creating a test event, then checking Google Calendar on the website from my laptop and the event was there. Even today, I made an event on the phone and it's on the web page. In fact, I just corrected the time of the event from the web page and the change was reflected almost instantly on my phone.

I tried unchecking the account sync and then deleting local calendar data, then rebooting and resyncing. But the problem persists.

What's wrong? Is there anything I can do? (besides factory reset please!) Or should I just check the "Do not show again" box? Or would that cause a problem later on?

As a side note Samsung Kies popped up first saying it couldn't sync, but I couldn't care less about that since I only made a Samsung account for the find my phone feature and the developer stuff.

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

If you go into the Calendar app and press the Menu button, then select Settings you should see an options at the top for Calendars this should show all of the individual calendars on your device that are being merged together into the Calendar displayed.

The top one is probably My Calendar then below that should be an entry for your GMail calendar, then maybe Facebook, or Contacts' Birthdays, and any other calendars you may have access to. The My Calendar calendar is purely held locally on the phone, it doesn't sync to GMail at all.

If you don't want to use that, then take the tick out to stop showing it as it sounds like you'd rather have everything syncing to the GMail calendar. Next time you create a new appointment in your calendar scroll down the Create screen to where it says Calendar with a right poiting arrow, select that to make sure that it is saving to your GMail calendar. If so, then you can safely tick the "Do not show again" box on your warning, as you don't care about the phone's local calendar you're saving straight to your GMail calendar anyway.

share|improve this answer
1  
Some calendar apps also have a Default calendar option that selects the, well, default calendar. I think on your phone the default is the one where the last new event was saved. –  onik Sep 21 '11 at 7:05
    
All I have is "Calendars" which lists: All, my, email@gmail.com, Canadian holidays, phases of the moon. I tried un-ticking all calendars except the gmail one and all except my calendar option. Neither solved it. –  Portaljacker Sep 21 '11 at 13:40
    
I honestly couldn't fix it but it was saying to my email bu default so I told it to not bother me again. –  Portaljacker Sep 21 '11 at 18:52
2  
@Portaljacker the point is that I don't think that message is telling you that there's a problem that needs fixing, it's just a badly worded way of letting you know that if you save to the local calendar it won't sync to the web, and that if you want to sync to the web you should save appointments in your GMail calendar. Once you've read the message and decided which you want to do you can safely tick the Don't Show Again box and forget about the whole thing. –  GAThrawn Sep 23 '11 at 12:49
    
related: android.stackexchange.com/questions/25210/… –  jozxyqk Sep 13 '13 at 7:16
add comment

I experienced the same, and followed your suggestion to ignore the message. Now it works fine! You should do that as well; no sense in not ignoring the error message if everything else works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.