Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have installed Droid VNC Server on my Android phone 2.2 (CyanogenMod), but it is not clear how to control now my phone via USB.

When I start the server on the phone it gives me an IP but I cannot ping to it. I cannot neither connect using the browser at the specified address nor through VNC client.

I have root access.

Can someone explain me the steps to follow?

share|improve this question
add comment

1 Answer

up vote 7 down vote accepted

There's no manual or FAQ I've found for the program so I'm not certain if this is the way they intended it to be used. It does work, though, and I can't see an alternative method of using USB.

  1. You need ADB installed along with the proper drivers for your device. This varies with platform and phone, so check Google or XDA.
  2. Enable USB Debugging on your device -- Settings > Applications > Development > USB debugging
  3. Plug in, start droid VNC server
  4. On a command line, run these commands:
    • adb forward tcp:5801 tcp:5801
    • adb forward tcp:5901 tcp:5901
  5. Visit http://localhost:5801 with a browser or point your VNC client to localhost:5901

I do notice that performance isn't any better over USB vs a 802.11g, so I'd only recommend going to the trouble of this if accessing your device via WiFi isn't feasible.

share|improve this answer
    
It worked thanks a lot! Only problem using browser it answer but show only two links to TightVNC and the author site. I use UltraVNC Viewer instead to connect and works very well. –  Drake Sep 23 '10 at 10:12
    
You might not have Java installed, or the Java VNC client had some problem loading on your system. Either way, doesn't matter since UltraVNC worked for you. –  Saiboogu Sep 23 '10 at 11:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.