Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Last week, my LG Optimus V started having a strange problem. Steps:

  1. Open Clock
  2. Tap "Alarms" icon at the bottom of the screen
  3. I must enter my pattern to access alarms
  4. Do anything else in Clock
  5. … ?
  6. Exiting Clock requires entering lock pattern

This happened once before, but I don't remember what I did to fix it, or even if I did anything (it might have just fixed itself).

Had anyone else had this problem? What did you do to fix it?

Edit: The screen is locking when the main Clock screen (Activity?) is displayed. Exiting from Alarms (for example) doesn't require unlocking the phone again.

Edit (2011-12-20): My solution was to download Alarm Clock Launcher and just bypass opening Clock. My Optimus still has this issue; we'll see if I end up having it on my new Motorola Triumph.

share|improve this question
    
Have you tried clearing the cache and/or data for the Clock app? This might help: android.stackexchange.com/questions/13347/… –  Al E. Sep 24 '11 at 3:02
    
All that did was delete my alarms. :-/ –  dgw Sep 25 '11 at 9:30
    
This resolved itself a day or two ago. I have no idea how. Wish I could vote to close. –  dgw Nov 9 '11 at 8:11
    
The issue has returned. Perhaps I shouldn't have been so hasty in requesting that this question be closed. –  dgw Nov 13 '11 at 10:48
add comment

2 Answers 2

I haven't figured out what the problem was, but I did find a workaround for my particular use case: Install Alarm Clock Launcher (donate version).

That way, I can change the alarm clock settings without having to unlock my device twice.

share|improve this answer
add comment

I had the same problem. Phone screen used to get locked when i tried to access clock(from widget or from home.) Had to disable the lock pattern.

Anyhow, my solution:

  1. goto -> setting -> applications -> Manage Applications -> Running -> Clock
  2. Clear data.

activated the lock pattern & clock was working now!!

Cheers!

share|improve this answer
    
Sounded like it was worth a try. Tried: disable screen lock security and clear data for Clock, then 1) set up lock pattern & test Clock and (after clearing/disabling again) 2) run Clock then reconfigure screen lock. No joy. It sounded so plausible, too. :-/ –  dgw Oct 20 '11 at 21:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.