Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My phone is Sony Ericsson Xperia X10.

I just updated my phone's software to the latest Android version (2.3.3), however, I've found that I can't download some applications. It would start the download and within 5 seconds, I get a message (from my notification bar) informing me that the "download was unsucessful" I have tried downloading it several times after with the same result. Please advice!

share|improve this question

I would trying Force Closing and clearing the data for the Market in Settings -> Applications -> Manage applications and rebooting your phone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.