Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Xperia Mini Pro that run on Android 2.3.3

I don't normally turn off the auto-sync, but my wifi is rarely turned on. I don't use 3G either.

The problem is, whenever I'm in a wifi zone, though the wifi is off, my phone will auto-sync. As in, I'll be notified about new mails and twitters updates. What can I do about this?

share|improve this question

closed as too localized by Bryan Denny Dec 28 '12 at 14:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Are you saying that you don't use 3G, have WiFi off and yet when you go to WiFi zone, your phone syncs? –  roxan Oct 1 '11 at 10:28
    
Sounds like you have Wi-Fi on and your phone is automatically connecting to open (unsecured) networks. How are you turning it "off"? –  Matthew Read Oct 1 '11 at 20:10
    
@roxan, yes, exactly –  Phelios Oct 2 '11 at 12:01
    
@MatthewRead, it only get synced when I'm in a wifi zone where I connected before, such as at office and home. I use the on/off widget, but when I check inside the setting, it's definitely off too. I also tried to browse the web but it doesn't work. So the WiFi is definitely off. –  Phelios Oct 2 '11 at 12:04
    
Hmm, so it's lying to you about being off. That's odd... –  Matthew Read Oct 2 '11 at 15:48

Browse other questions tagged or ask your own question.