Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

After spending a few moments moving some apps from my phone's internal storage to my SD card, I'm no longer able to download/install apps.

Every time I try to get one (like the Wikipedia app) I get the bellow weird alert, saying that my phone is not compatible with the item I'm trying to download.

Screen shoot

I can update apps already installed, though.

How can I solve this problem? This is my first Android phone (ZTE Blade, commonly known as "a5" in Portugal) and I have no idea how to solve this issue. I have Cyanogenmod installed and all caches have been dumped.

EDIT: I've simply uninstalled the updates for the Market app, downgrading it to the 'old' Market and it just worked!! I could easily download and install new apps, but when the Market app re-updated itself automatically, I couldn't download/install any apps again.

share|improve this question
    
Did you move the 'Market' app? –  P.T. Oct 4 '11 at 17:12
    
Have you tried wiping and reflashing? –  kyrias Oct 4 '11 at 17:42
    
No I didn't, @P.T. I'm not even sure what that is, Demizide, but I'll google it and try it out. –  João Ramos Oct 5 '11 at 19:35
    
EDIT: I've simply uninstalled the updates for the Market app, downgrading it to the 'old' Market and it just worked: I could easily download and install new apps, but when the Market app re-updated itself automatically, I couldn't download/install any apps again. –  João Ramos Oct 7 '11 at 10:23
2  
@JoãoRamos: Don't apologize for your written English. It's better than a lot of native speakers. –  Al E. Dec 6 '11 at 13:55

2 Answers 2

just get a way to download Mobomarket, and you can use that app to download others, infact it works more or less like google play app. its not necessary to delete anything, unless you cant download the app(mobomarket) itself.

share|improve this answer

When the market re-upates itself. Goto:

Settings > Applications > Manage Applications > Market

and select 'clear cache'

Now go back into the market and re-signin with your market account. See if this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.