Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am trying to figure out how to have only one notification icon on the top notification bar for an incoming e-mail for any of my multiple Gmail accounts. This was the way Gmail worked on my phone prior to the 2.3.5 Gmail update.

Now, at any given time I can have up to four little Gmail icons on my top notification bar which is an pain.

Is there any way to change it to the way the notifications worked before?

That is, one icon for all my accounts, and if I receive an e-mail, it sends me to the main accounts page.

share|improve this question
1  
That appears to be by design, since you can have separate notifications (including different sounds) for folders within the same account, even. I'm afraid that there's no way to go back with the existing app. –  Al E. Oct 7 '11 at 16:19
    
I've had that behavior on my Droid since Android 2.2, maybe even 1.6; not sure of the corresponding gmail versions. I don't remember it ever working differently. You could turn off notifications for some of the accounts. –  TomG Oct 8 '11 at 0:06
add comment

3 Answers

You could set up one of the accounts to read the other accounts; that way you would only need to sync the one email account.

You will still be able to send from the correct account - there is a setting to send from the main account or from the account the original email was sent to.

I use one Gmail account to collect the email from several email accounts (gmail and ISP). I set it up so can I also send email from any of the accounts. That way I only need to log into one account.

share|improve this answer
add comment

It is almost certainly a new feature, as there was a software update for GMail earlier today. I have gone through the settings, but unfortunately, I can't seem to find an option to get the previous one-icon notifications...

share|improve this answer
add comment

I'm running 2.3.5.2 and I am now experiencing the same issue.

I'd recommend just resetting the app's cache, it may of just got into a muddle.

settings > applications > gmail > click > clear cache

share|improve this answer
4  
No, it's by design. –  Al E. Oct 7 '11 at 16:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.