Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After replacing my ailing Nexus One with with a SGS2 yesterday (an ordeal in and of itself, but neither here nor there), I decided to replace the stock ROM including TouchWiz with something a little more familiar, hence Cyanogen. I've was following these instructions, and it was going relatively well until step 9 under Method via Recovery. The first time around, I had placed the zip files directly on the root of the SD card, but I couldn't find them. After several more attempts, using different locations, attempting to put them on the internal storage, etc, I still haven't found a way to load those zip files.

Directory Listing

As can be seen, I don't have a mount point named sdcard as is typical. I do have that external_sd folder, but whenever I try and enter it to select a zip, I get an error saying something like "No Files Found" and am just returned to this folder.

Any help would be appreciated.

share|improve this question
up vote 3 down vote accepted

The folder you're seeing is the internal SD one. Just put your file there and search for it, it might be hidden in the scroll, just go down and it will show more files in the folder.

To make the process a lot more easy, just rename your *.zip to, but the file in the root of the internal SD card folder and use the Install from internal SD method.

share|improve this answer
Much thanks. Still not sure how to put a file there over USB, but using ASTRO File Manager, I made it happen. – MBraedley Oct 23 '11 at 13:57
Ahh, nice to see that you made it, it's a pleasure for me to help :) – Nathan Campos Oct 23 '11 at 13:59
@MBraedly Your PC should see two drives, one's the internal SD and the other's the external. – Matthew Read Oct 23 '11 at 15:56
@MatthewRead: I see the 2 drives, but when I was trying this, it wouldn't let me put anything on the internal one. If I tried putting a file on the root, it would silently fail, if I tried one of the folders, it would say I didn't have permission. Not sure that's still the case, but I haven't tried since CM7 up and running. – MBraedley Oct 29 '11 at 16:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.