Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Upgraded my HTC Slide to Froyo. Connecting Ubuntu 10.10 via USB.

As per instructions here, http://developer.android.com/guide/developing/device.html

    $ cat /etc/udev/rules.d/51-android.rules
    SUBSYSTEM=="usb", ATTR{idVendor}=="0BB4", MODE="0666", GROUP="plugdev" 
    $ ls -l /etc/udev/rules.d/51-android.rules
-rw-rw-rw- 1 root root 72 2011-10-23 20:57 /etc/udev/rules.d/51-android.rules
    $ adb devices
    List of devices attached 
    ????????????    no permissions
share|improve this question
4  
did you execute chmod a+r /etc/udev/rules.d/51-android.rules ? –  Reno Oct 24 '11 at 2:42
    
Check you have usb debugging enabled and plug out and in again –  daithib8 Oct 24 '11 at 19:41
add comment

migrated from stackoverflow.com Oct 24 '11 at 10:41

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 4 down vote accepted

Had this very issue earlier tonight myself.

The 51-android.rules needs to be world read-execute, and it's probably best to run service udev restart (or reboot) after changing this, then re-plug your device.

If it still doesn't work, double-check the vendor ID you've supplied; with your Android device connected, run lsusb. HTC also use the vendor ID 18d1 on newer devices.

share|improve this answer
1  
Or /etc/init.d/udev restart –  whuiscool Oct 24 '11 at 14:36
    
My HTC device is at least an year old. Yet, I had to use 18d1. The android website says 0bb4. Dont know why 0bb4 doesnt work any more. developer.android.com/guide/developing/device.html Thanks for the answer. –  Anil Nov 23 '11 at 13:34
add comment

I had this issue myself when rooting my kindle fire and I did:

$ cat /etc/udev/rules.d/51-android.rules     
SUBSYSTEM=="usb", SYSFS{idVendor}=="1949", MODE="0666"

Then in my ~/.android/adb_usb.ini file I added

0x1949

Where 1949 is the vendor id for the kindle I believe.

And after restarting the box, adb devices shows my kindle. Or instead of restarting udevadm control --reload-rules and adb kill-server && adb start-server should be sufficient.

share|improve this answer
add comment

If you only need to work with devices on a very infrequent basis, you can restart the adb server daemon as root.

./adb kill-server

sudo ./adb devices

Please note that it's not a good idea to make the daemon run as root - any security issues in the daemon will now have root access and ANY user on your system who can run adb (not just your user account) can access the devices - as you're basically ignoring all permission settings in 51-android.rules.

As of note, you do not need to be root to shut down the server - just use ./adb kill-server again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.