Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

There's an Asus 240 MIMO Wifi access point. There's a laptop running Windows XP that uses that access point no problem for years so far. And there's an Android based HTC Desire S smartphone that has problems. The objective is to make the smartphone access the Internet via the Wifi access point.

I open "wireless networks" configuration pane, "enable" Wifi - it goes through "scanning" and "obtaining IP address" stages, says "connected to TheRightNetworkName". The Wifi symbol is displayed in the bar under the top of the screen. Yet when I try to open any page in a browser if wouldn't do so and claim there were problems accessing that page.

I tried the following (listed in this answer below, thanks to user Matthew Read):

  • rebooted the phone - doesn't help
  • checked MAC filtering on the AP - it is disabled
  • disabled the firewall on the AP - doesn't help
  • tried to change channels - doesn't help, the AP has 13 channels if that matters
  • tried to change to 2.4 GHz - looks like it is already the only option, couldn't find any way to change the range
  • didn't try to switch from WPA that is currently used to WEP because it feels quite scary - I can mess things up
  • tried switching modes - b, g, b/g - doesn't help

How do I debug and resolve this issue?

share|improve this question
    
What kind of security is on the network? WEP? WPA? It almost sounds like the network is using Mac address filtering. –  Charles Caldwell Oct 25 '11 at 14:16
    
@PortableWorld: WPA is used, no MAC filtering, I updated the question to include my findings. –  sharptooth Oct 26 '11 at 7:23
add comment

3 Answers

Make sure that you are using DHCP on your phone; if you have a static DNS set and it's the wrong one, you won't be able to browse the web. Go to Settings->Wireless And Network->Wi-Fi settings, hit the context button (or right click button, or whatever you call it), select Advanced, and make sure Use Static IP is unchecked.

share|improve this answer
    
DHCP is used - checked that already. –  sharptooth Nov 28 '11 at 6:05
    
As a complete shot in the dark, have you tried using a browser other than stock and seeing if that works? –  Logos Nov 28 '11 at 13:45
    
Yes, I tried Firefox - results are the same. –  sharptooth Nov 29 '11 at 6:03
add comment

Assuming that the smartphone connects to the AP as you say, try the following.

  • Take the IP of the phone.
  • Connect to the same AP your laptop
  • Run ping ip_of_phone from cmd (if you are using win) or from Terminal
  • If you can do a ping means that something is wrong, perhaps with the DNS
  • If you can not ping, probably something is wrong with IP assignment. Perhaps a two devices have the same IP. A common mistake is that people assign an IP to an AP and do not exlude that IP from the DHCP pool of the router.
share|improve this answer
    
I tried that - ping succeeds. What else can I check? –  sharptooth Nov 1 '11 at 7:56
    
Can you try using staic IP (whatever IP you are getting for the phone) and in DNS use 4.2.2.2 and 8.8.8.8 –  roxan Dec 26 '11 at 4:09
add comment

First ensure the phone is using the right password for the network and try rebooting the phone.

Then play with with your AP, one of these at a time:

  • Reboot it
  • Ensure MAC filtering isn't on
  • Try disabling any firewall it might have
  • Ensure it uses channel 1 or 6 or 11 (assuming you're in an 11-channel region)
  • Try switching to 2.4 GHz if it's broadcasting on the 5.0 GHz band
  • Try switching from WPA to WEP encryption or vice-versa
  • Try switching to or from mixed mode (e.g. 802.11 b/g rather than just 802.11b, etc.)

If nothing changes, please provide your phone model and I'll try to help further.

share|improve this answer
    
I checked everything except switching to WEP - that feels very risky. I updated the question to include my findings and phone and AP model. –  sharptooth Oct 26 '11 at 7:24
    
@sharptooth Fair enough. Does the phone work OK on other Wi-Fi networks? –  Matthew Read Oct 26 '11 at 12:36
    
Yes, it works on another WPA-protected network okay. –  sharptooth Oct 26 '11 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.