Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I recently installed CyanogenMod 7.1 on my Samsung Galaxy S i9000 and I have some problems now to get ADB on my Windows 7 64-bit computer to recognize the device.

Currently, adb devices returns no entry for my phone and the Device Manager shows a device called "Galaxy S" but with a yellow exclamation mark because a driver is missing.

I've tried to install Samsung Kies as well as the Google USB driver for Windows Revision 4 and point the device manager at the directories with those drivers. It doesn't find anything it can use there.

Which drivers do I actually need for the phone now that it is running CyanogenMod 7.1? And where do I get those and how can I install them?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Use the drivers that come with the android SDK. The samsung drivers do not work once CyanogenMod is installed.

share|improve this answer
    
That's one of the drivers I tried, if I point the driver installation dialog to the folder with the Google driver it just says that it didn't find any driver for the device. –  Mad Scientist Oct 27 '11 at 13:52
1  
make sure you have android_winusb.inf in the folder, there should also be androidwinusb64.cat and an amd64 folder. If you have those, it should find the driver. That is the driver I use for my Galaxy S w/ CM7 on both my work and home PCs both run Win7 64bit –  Ryan Conrad Oct 27 '11 at 14:10
    
Thanks, the Google driver is the correct one, I just pointed Windows to the wrong folder, the driver installation fails when I choose the amd64 or i386 subfolders, it has to be the parent folder. –  Mad Scientist Oct 27 '11 at 14:32
    
You can also just right-click on android_winusb.inf and/or oem6.inf and choose Install rather than going through the messy detecting/browsing for files/etc process. –  Matthew Read Oct 27 '11 at 14:49
    
i always got an error when I tried to "install" the android usb driver inf file. –  Ryan Conrad Oct 27 '11 at 18:51
add comment

For anyone else who struggled with not detecting their phone. Here's what happend to me: First I was trying to uninstall the automatic portable device that windows adds when I plug in my galaxy s3. That was silly seems if you manually install the driver it will pick up. I had to go to right click my computer -> Manage -> Device Manager - > Action -> Add Legacy Hardware -> Choose Android Phone -> Browse to ..\AppData\Local\Android\android-sdk\extras\google\usb_driver and select android_winusb.inf -> Then I selected the "Android Composite ADB Interface" option

UPDATE

Ok, the above solution wasn't working any more after a reboot of my pc. So this time I saw my phone was under "Other Devices" in Device Manager. Clicked Update driver, choose from my pc, "Have disk..." and forced it to use the above mentioned composite driver despite the warning and then it worked again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.