Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

It takes almost more than 5-10 seconds to open the dialer application in my phone.

This has been happening for a while now and is especially critical since during incoming calls, when my phone snaps back from standby to show me who is calling, I actually have to wait sometimes more than 10 seconds to see the caller id and its like the phone is stuck during that time.

It has been the case before (stock) and after I've put a custom ROM in my phone. Though I noticed this became more severe after I installed a lot of apps etc.

Since I suspect that this is because of low free RAM (I have a low-end Android phone), I recently installed optimization apps, kept my homescreen free from widgets and running apps etc. and it did help to an extent. However, I feel like it still needs to be lightning fast and always accessible feature like in conventional handsets. How can I achieve this? How do I lock the dialer in my RAM or is there some super light dialer apps that can replace this stock dialer?

Also, could it be because I have around 150 Facebook and Google contacts synced in? (I don't think that is a big number)

How about finding a way to turn off the picture data in contacts? Will that reasonably reduce memory footprint?

Very same situation : Can I set it so the "Phone" on my phone takes priority over all other apps? (tried all the answers)

UPDATE: I found something called "FUSIONboost" on the FUSIONideos custom rom that seems to set the priority of apps or something. This seems to be exactly the solution, but I don't want to switch roms now and would really like if someone can tell me how I can get this..

share|improve this question
    
Will be glad if someone can give insight into what and how to get the FUSIONboost thing as I have a feeling that would be a more effective answer to this problem ; though I appreciate all your answers –  Power-Inside Dec 3 '11 at 4:54
    
It might be easier to suggest something if you say exactly which phone you have, and what Android version. Though I suspect it's too late now anyway. –  Dan Hulme Aug 9 '13 at 21:54

8 Answers 8

I experienced a similar situation with my Samsung Galaxy GT-i5700 (SPICA), and I got up to a very weird solution to this:
It seems that the huge number of SMS was causing the mobile to further slow down (apart from the large number of apps in the device). I then deleted many of the messages, and there was a significant improvement in the dialer operating speeds.
I don't know whether the same thing would work for you, it's only a loophole I discovered on my mobile (Fact: Samsung SPICA can only accomodate up to 2000 SMS). I can only say you can give it a try (of course, this stands true only if you have many SMS stored on your device).

I don't have answers for the other factors.

share|improve this answer
    
Clearing call history had helped me once. Not sure if it will help you also. –  roxan Nov 15 '11 at 12:53
    
I don't know if this validates what @SamSPICA says or not, but I use Google Voice exclusively for my SMS, so I don't have any messages stored in the default SMS app, and I've not seen any issues with my dialer app. –  Al E. Nov 15 '11 at 14:05
    
That's weird because Messaging and Dialer are different "apps".. but I'll try (I dont think I have more than 500 sms though so it shouldn't make much difference?) –  Power-Inside Nov 17 '11 at 13:47
    
If they're not more than 500, I don't think it might make much difference, because I had around 2000, now I never let the number go beyond approx. 1500. –  SamSPICA Nov 17 '11 at 18:13
    
@Power: and u might wanna know that they're both a part of the same package (com.android...) –  SamSPICA Nov 18 '11 at 6:22

Slowdowns like this on phones older than 1 year old are most likely a side affect of memory shortages. To check to see if this is the issue, go to the Android settings and look at SD card & Phone Storage. The last item, "Available Space" should be 17 Mb or more.

If you are using the Email app (NOT Gmail) then you should check your trash folder. In mail, hit Menu, then choose Folders and scroll down to Trash. Email NEVER empties the trash folder, even if you have deleted hundreds of messages. You will either have to delete them manually or delete and re-create the account.

Sometimes the browser builds up a large set of data. You can go into browser settings and hit Clear Cache. But there seems to be even more data associated with the browser. It is easiest to go to the overall Settings, Applications, Manage Applications, then choose the All tab and find Browser and tap on it. Then click on the action to Clear Data. This will delete your bookmarks as well so you should make note of them first.

Finally, you may have background tasks that are hogging the phone's CPU time. You can get an app like Advanced Task Killer (free version avail.) that will periodically kill off any apps that you don't want. For instance, the Skype and Backup apps on Verizon phones run in background all the time but are generally not needed.

share|improve this answer
1  
As I've just clarified in my post above, be careful not to lump together "memory" into one heap. It's very important to distinguish between persistent storage and transient RAM. Clearing space on persistent storage by deleting emails or moving apps to the SD card will rarely have any effect on performance. To perform well apps need RAM. –  Martin Dec 1 '11 at 22:58
3  
Also, Android has a very advanced task manager, which uses a complex algorithm to determine when to kill a task. If there is memory that is not being used or needed by another app, it doesn't kill it. Task killers do not have the same metrics, and cannot make the same informed decisions. Task killers will often reduce performance by unnecessarily unloading Services or Activities from memory, only for them to be loaded again when they are needed (sometimes immediately). –  Martin Dec 1 '11 at 23:04
1  
Just a small note, I've noticed that stopping tasks by using the froyo's "force stop" option works much better than any task managers.. –  Power-Inside Dec 3 '11 at 4:51

This is likely a combination of two things: a) stuff that the dialer has to load on startup and b) possibly shortage of memory (RAM) created by loading those things. The biggest gains are to be had by resolving (a) however, this will also have the side effect of resolving (b)

You might like to try clearing the following:

  • Call log - this is loaded each time the dialer is loaded.
  • SMS messages - Some users have reported that a large number of SMS messages can cause the dialer to slow down, though I'm sceptical that this makes a difference.
  • Contacts - finally, the number of contacts does have a bearing. Not only the ones you can see ("My Contacts"), but anyone you've ever emailed (i.e. Other contacts in GMail contacts).

The last point can be quite important. I have about 130 'real' contacts but nearly 1000 people I've emailed at some point while using GMail. There were all being synced to my phone, just not always shown.

It is important to make the distinction between RAM and persistent storage. For example, clearing out your trash, deleting emails, uninstalling unused apps, or moving them to SD storage is unlikely to help, because these are using up persistent storage, not transient RAM.

Having lots of persistence storage free means just that apps can't use it to run any faster. RAM, however, can make them fly.

You might also like to take a look at Superdial and Dialer One, two dialers that I've found most agreeable. They also have T9 contact lookup, which can be a dream to use.

share|improve this answer
    
Just tried DialerOne and its fast and smooth (though I disliked the UI ; but performance is the key). Let's see how well this works in the long run. Thanks a lot! –  Power-Inside Dec 3 '11 at 5:24
    
I'd also recommend having a look at exDialer. –  masterjo Dec 20 '11 at 12:58
    
I had a similar issue on my Samsung Galaxy Chat where I had a few thousand SMS messages in one conversation. The dialer reacted slowly for me (but not in the order of magnitude what the OP experiences). After deleting the SMS's the dialer worked normally. –  Andris Dec 10 '13 at 8:39

You could attempt a factory reset, but like you said you do not want to wipe data. Do not use task killers either they will bog your phone down a great amount. Also check to see what apps are using a lot of RAM. Go to manage applications and view running applications.

share|improve this answer

I agree that this is a memory issue. I've had times with my previous phone in which my phone froze as soon as it turned on because of memory issues. If you have Froyo or above, move as many of your big apps as you can to the sd card. If you have already done this, uninstall apps to free up memory. Morris suggested 17MB. This sounds small to me, and I think the actual number depends on which version of Android you have and what types of apps you use.

share|improve this answer
    
Im using link2sd on all apps and I do have around 30 MB free internal space.. still the same. –  Power-Inside Dec 1 '11 at 12:46
    
@Power-Inside See my edit and comments above. Available storage freed up by link2sd or freed manually is unlikely to make any difference. –  Martin Dec 1 '11 at 23:06
    
@Martin I agree.. But I thought maybe the minimum storage also played a part maybe since it might be used as a virtual memory or a page cache or equivalent.. –  Power-Inside Dec 3 '11 at 4:44

I had similar problem, though we cannot completely rectify this we can reduce the startup time by these approaches,

  1. Contacts -> More -> Check 'Only contacts with phones', select only required groups in the bottom groups, better u can create a starred group and select it.

  2. Use 3rd party Contacts app like Go Contacts - https://market.android.com/details?id=com.jbapps.contact to view the complete list of contacts

  3. Never press back button to exit the dialer, use home button to exit dialer, pressing back will kill the dialer activity

you can also try Go Dialer or https://market.android.com/details?id=kz.mek.DialerOne&hl=en

share|improve this answer
    
Go Dialer actually slows down more than the stock dialer. +1 for giving me idea to not use the back button. I now have a half baked solution of simply opening the dialer and exiting it using the end key and I do this periodically so I can hope most of the time the dialer is going to be there in the RAM –  Power-Inside Dec 3 '11 at 4:47

try this low-end dialer app, http://www.appstorehq.com/dialerone-android-155708/app

gingerbread update has been officially available for Huawei IDEOS now, try that !

share|improve this answer
    
yes, someone has already suggested the Dialer One app before you. Perhaps I'd give a +1 if you can provide links to official gingerbread for my ideos because Im not seeing it anywhere. –  Power-Inside Dec 3 '11 at 12:00

If you have installed any call blocking apps, uninstall and see if you get an improvement. (It worked for me.)

share|improve this answer
    
What makes you think the OP installed call-blocking apps? No mention in the OP's question... just saying –  t0mm13b Aug 9 '13 at 22:25

protected by Community Dec 10 '13 at 11:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.