Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I installed Cyanogenmod on my HTC Desire about a month ago and have just received my first mobile bill. Before installing Cyanogenmod, I'd use maybe 200-300MB per month, because most places (home/work) I spend time have Wi-Fi that I can use. I have scheduled downloads of podcasts over Wi-Fi, configured to only use Wi-Fi (BeyondPod)... although I found that this setting had been unset when I changed from having 2 accounts on the phone (one Google Apps and one not) to just having 1 (Google Apps)... so I guess the preferences had been saved under the account I removed.

Have had just received my first bill since I changed to Cyanogenmod and I've apparently used 4GB of data! That's going to cost me over $100 extra, so I'm not best pleased.

Some points/thoughts/questions...

  • I have Wi-Fi and mobile data enabled all the time.
  • Podcast downloads were scheduled for 4am so, even with the "only use Wi-Fi" option disabled, it should have downloaded over Wi-Fi at that time as I spend nearly every night at home and therefore on Wi-Fi
  • Sometimes when I unlock the phone, I see the mobile data symbol on screen briefly as well as the Wi-Fi one.
  • Is there a setting somewhere that is turning off Wi-Fi when the phone is locked?
  • Is there a way I can prevent the phone from using mobile data when it's connected to Wi-Fi... and how do I make sure it's connected to Wi-Fi as much as possible?
  • Anyone got any tips/tricks to share for this scenario?
share|improve this question

1 Answer 1

up vote 3 down vote accepted

Go into the Wi-Fi settings, press Menu, choose Advanced. You should get options including Wi-Fi Sleep Policy. Sounds like its set to turn off Wi-Fi when the screen is off.

share|improve this answer
    
Yes, it was set to sleep when the screen was off - I've now set this to never sleep. Hopefully that doesn't mess up my battery life too much, it was already pretty crappy. I turned mobile data off altogether yesterday and my podcasts updated overnight, so they must have gone over wifi... so not 100% sure this is the cause, but thanks for the pointer, will see how it works out. –  x3ja Nov 7 '11 at 18:23
    
That seems to have fixed it, thanks for the pointer. Also battery life has improved a lot with turning this setting on... I guess 3G uses more than wifi... –  x3ja Nov 15 '11 at 18:12
    
Thank you so much! I was wondering why I was consuming data around the house (where there is a WiFi connection available). Sure enough... WiFi was set to turn off when the screen shut down unless the 'phone was plugged in. –  Richard J Foster Dec 12 '11 at 15:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.