Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Google Nexus S with Android 2.3 in it. I want to tether/or enable Wifi HotSpot in it. Do I have to root my phone?

How should I proceed?


share|improve this question
Do you have Settings->Wireless and Networks->Tethering & portable hotspot? – eldarerathis Nov 8 '11 at 15:51
Yes, I have this option. But when I did that the wireless connected gadgets to my phone didnt have the access to the internet. – RG-3 Nov 8 '11 at 17:32
up vote 2 down vote accepted

No, you don't need to have your phone rooted to enable a portable hotspot.

Not quite sure why it isn't working for you, but here are the reasons it hasn't worked for me at various times.

  1. No cell data connection. I've tried using the hotspot as a relay to another wi-fi network without any success. The original wi-fi connection is shut down.

  2. Misconfigured wi-fi security on the attaching devices.

share|improve this answer
Do I need to enable HotSpot through Sprint? Because that is another $20/month :( – RG-3 Nov 14 '11 at 14:35
My first thought is no, but I bought my phone from Best Buy without a plan. I can activate the Hot Spot if I bought the old day pass from T-Mobile or switch for the day to T-Mobile's $2/day data plan. I've been able to turn on the Hot Spot on demo phones at various cellular providers when I've fiddled with their phones. But, if Sprint has modified the Android OS, you may have to buy the Sprint package. I'm just not sure. You'll need that answer from someone who has the Google Nexus S from Sprint. Did either of my suggestions help? – Richard Povinelli Nov 14 '11 at 23:00
Yes, thanks Richard. Marked your answer! – RG-3 Nov 15 '11 at 14:08
Hey Richard, I downloaded EasyTehter App from the market place and connected to my PC via USB cable through my phone, it worked like a charm. But when I am enabling HotSpot through my phone settings then it does not work. Any clues whats going on? – RG-3 Nov 16 '11 at 16:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.