Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy Ace and I've encountered a strange issue. When I was connecting my mobile to the PC I unchecked the box for "USB debugging mode" and did my work without issue. However, after some time passed and I again tried to connect my mobile to same PC, it was unable to connect. When I checked my settings, I noticed that USB debugging had become re-enabled again. Is there anything I need to set to disable USB debugging permanently, or is this the default behaviour of the Samsung Ace?

share|improve this question
I would uncheck it and then reboot before connecting to anything. –  Matthew Read Nov 14 '11 at 20:52
why reboot, does it actually require... –  Abbas Nov 14 '11 at 21:07
No, it shouldn't require that, but I thought it might work. –  Matthew Read Nov 14 '11 at 21:15

1 Answer 1

This happens to myself, you would have to turn the device off several times whilst your USB is connected and just wait for it to stay turned off, once its turned off it will not turn back on unless upon reconnection. It's a very old phone and is not a good phone so this is why it's like this. I wish there was a better resolution myself but after browsing the internet for around an hour I figured I'd help a somebody else and let them know what I know.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.