Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My DroidX just got upgraded to 2.3.15 (android version shows 2.2) over the air. After the upgrade the phone forced me to set a pin number. The phone is not currently connected to an Exchange server, but it used to be. A couple of weeks ago I removed then Exchange settings for contact list sync and I uninstalled TouchDown.

The strange thing is that the Exchange server that I was connected to didn't have a requirement for a password, so I'm not sure where this setting is coming from. When I look in Location & Security > Select Device Administrators I see "Corporate Sync" listed in there, but there doesn't appear to be any way to remove the settings.

I no longer work for the company with the exchange server, so I can't connect back to it. I'd rather not wipe the phone and reset it if I don't have to. I would also prefer not to root the phone as well.

share|improve this question

6 Answers 6

  • Open up My Accounts application from application tray.
  • Select the Corporate Sync account you wish to modify.
  • Your Corporate exchange account settings will be displayed
  • Select Remove account to remove this Corporate Exchange account from the handset.

Seen here

Troubleshooting page in case of further problems.

share|improve this answer
    
There's the problem. I don't have a corporate account listed there. I've got the stupid Verizon Backup Assistant, my two non-gmail POP3 email accounts and my gmail account. –  mrdenny Sep 27 '10 at 0:00

I just upgraded as well and had the same thing happen to me. However, in my case I am still connected to an exchange server. I know our IT guys are very open with not locking down our phones with stuff like this and I have had Windows Mobile phones connected to the same exchange server with no need for a pin number.

  • Open Phone Settings
  • Open Location and Security Settings
  • Go to Select device administrators

Mine currently says "Corporate Sync" is one of the device administrators, but doesn't allow me to remove it. You may be able to remove it since you have removed the connection to the server.

I suspect either the phone wasn't enforcing the settings set by the exchange server correctly or that there has been a bug introduced in the new version.

NOTE: I know this wont work for the person asking the question, but might be helpful to others. I was able to remove my exchange account, change my password back to Pattern instead of PIN, re-add my exchange account, and the phone did not force a PIN to be set.

share|improve this answer
    
Lucky. So far I've had no luck. May have to setup an Exchange server to connect to just to remove these settings (if that will even work). –  mrdenny Oct 2 '10 at 22:01

FOR ROOTED PHONES ONLY

Well I've had the same problem as the original poster ever since I updated it to Froyo. My exchange account I previously had on the phone was using a remote administrator certificate that I could not remove. Yesturday I worked out a simple solution using R/W access to the /system/app folder.

Using a free root file explorer named Super Manager. I navigated to /system/app and renamed the file PolicyMgrProvider.apk to PolicyMgrPrivider.bak. This removed the remote administrator policy and allowed me full control over the lock screen. After I switched it to No Lock I went back and renamed the file to PolicyMgrProvider.apk.

No problems what so ever.

I did rename the file BlurEmailEngine.apk to a .bak at the same time, so if its not working disable that app as well long enough to change your lock screen settings.

I know you don't want to root your phone, but unfortunately its probably the only way you'll get that stupid PIN lock gone.

share|improve this answer

I tried the suggestions here with no luck. The solution I tried only works on a rooted phone. Background: Removed Exchange/Corp Sync account, screen lock remained, and could not be disabled.

Solution requires a Rooted phone, installed a Terminal emulator, installed Busybox - need to edit one or two files with unix 'vi' command

DroidX: Open terminal emulator. su cd /data/system vi device_policies.xml Open a line below policies Add Escape out and save file :wq

Check list of files with ls command ls

The Droid 3 had a file called mot_device_policies.xml which additionally needed the same changes as described above.

The changes comment out the policies and after a reboot, you can turn off the screen lock!

share|improve this answer

FWIW, I just tried the steps posted above by mru and they did exactly what I wanted - removed the corporate account and freed my lock screen.

That said, there was one very minor glitch. I tried to remove the PIN requirement immediately after I removed the account, but the system would not let me. As you can imagine, I was disappointed. But I went in awhile later, and the restrictions had been removed. I had to enter my PIN one more time, and that let me reset the security to my preference.

share|improve this answer

Android 4.4 makes it easy.

It allows you to remove this (at least for me it did), by selecting the option, Clear credentials (Remove all certificates) from the Security menu. Immediately, I was able to set no password/lock-code on my device again.

Hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.