Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I bought a Galaxy S II GT-I9100G two weeks back from Malaysia and it was running on Android ver. 2.3.5. But three days back I saw a 2.3.6 update available and updated my phone using the update option available in the phone. But now when I connect phone to PC via USB it shows unknown device and Windows cant find the driver suitable for it. And so I can't transfer files to or from my PC. Could anyone please help me out here?

My PC is running on Win7 x64.

share|improve this question

5 Answers 5

Worked for me:

  1. Unplug the USB cable

  2. On the cell phone, dial the following number: *#7284# Once the last # is hit, the PhoneUtil application is launched. Choose USB -> Modem and then USB -> PDA mode. The good mode should be PDA. Even if the mode is PDA, switch to Modem and then back to PDA.

  3. Plug the USB cable.

Note:

  • Repair USB connection for any Samsung Android phone

Reference: http://www.youtube.com/watch?v=KV2h5O_qDPE

share|improve this answer

Try installing Kies (check the "Software" subtab under "Downloads"). It should install the drivers automatically but if not it has a menu option to install them.

share|improve this answer

Do a Factory Reset through Privacy menu of Settings. It will solve your problems

share|improve this answer
    
it worked for me –  user13015 Mar 1 '12 at 7:41

On your phone got one software call "Kies" try to using wifi to connect to the computer and the phone where in the computer you key in the IP address shown on your S2 and after that the driver will automatic installed its work fine for me after i use KIES to connect to the computer and again the computer USB can recognized my phone =)

share|improve this answer

"Just make sure you use a USB port on the back of your computer. Front ones can be less than perfect as there is cables, noise etc." This fixed my USB connectivity and transfer problems.

share|improve this answer
1  
the OP's problem started with updating to 2.3.6 only. This is obviously not hardware (USB) related. –  ce4 Aug 21 '12 at 21:45

protected by Community Jun 6 '12 at 2:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.