Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm running Liquid Smooth 3.2 on my Motorola Droid 1. This ROM comes with logcat disabled (/dev/log/main doesn't exist). I tried starting the logcat service myself by adding the following to /etc/init.local.rc:

#start logcat service
service logcat /system/bin/logcat -f /dev/log/main
   oneshot 

However, this didn't seem to work as /dev/log/main still doesn't exist on boot. I'm getting...

$ logcat
logcat
Unable to open log device '/dev/log/main': No such file or directory

Does anyone know how to re-enable logcat in a ROM that has it disabled?

share|improve this question
    
Looks like Franco's Kernel is another that doesn't let you use logcat. Is there any way around it for Franco's? facebook.com/franco.Kernel/posts/289634051051987 –  NoBugs Mar 21 '13 at 1:43

2 Answers 2

The ROM might call "rm /dev/log/main" during init to cripple logcat. If you can find that line and remove it logcat should be happy.

share|improve this answer
    
Thanks for the hint! I'll do some grepping and see if that's the issue. –  William Tate Nov 27 '11 at 20:07
    
Why would a rom do that? –  NoBugs Mar 20 '13 at 2:49
    
@NoBugs There's a slight speedup if the OS isn't logging as it's running. –  jarvisteve Mar 20 '13 at 3:33
up vote 2 down vote accepted

I figured it out. It was the kernel that came with Liquid Smooth ROM. The kernel developer, chevyno1 (of Simply Stunning MOD), disabled logging in the kernel. I switched to a different kernel by JDLFG and logging immediately turned on with the next boot.

share|improve this answer
    
Switching kernels helps - in my case Goldenleaf works instead of the old Franco's. –  NoBugs Jun 12 '13 at 5:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.