Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

First-time smartphone owner. I unboxed my new Nexus S and added my gmail account to it. So far, so good -- it sync'd my contacts perfectly.

But I'd never used Google Calendar (and in retrospect I think that's crucial).

So I signed on via my computer, went to Calendar, and set up a calendar with two events (one repeating, one not).

Then I went back to my phone and I find that in the calendar app I have no calendars. There are no events showing and I can't add events ("You have no calendars."). Moreover, in the Accounts & sync settings, under my gmail account, there is no Calendar item, just Books, Contacts, gmail.

I've waved every dead chicken I've heard of at this one, to no avail. The list of sync items won't grow a "Sync Calendar" item. To wit:

1) Obvious first choice, I thought. Power off the phone, power back on. Nope.

2) Read the FAQ Google Support FAQ
2a) Turned the auto sync off and on. Nope
2b) No notifications.
2c) Don't have a 2-step authentication.
2d) Cleared Calendar Storage data, power off, power back on. Nope.

3) Power off the phone, change my gmail password via web, power back on, re-authenticate. Nope.

4) Go to Accounts & sync, create a new google account, create a calendar in it, power down the phone, power back on. The new account has a Sync Calendar item that works, but not my real gmail account.

5) Go to Applications, all, and delete the data for "all the Google apps", power down the phone, power on. Nope. A caveat on this one, I don't know exactly what "all" means, so I hit Calendar & its storage again, Books, Contacts, gmail, everything whose name began with Google,...
see: Related Question
Ok, different device, but otherwise the description seemed a close match. Nope.

So...

Any other suggestions?

share|improve this question
    
Have you tried setting up the Google Calendar from your computer first? I don't think it can be done from the device. Once it is set up it should sync to the phone. Those events you created are probably just in the phone calendar and not the Google calendar because you don't yet have a Google calendar. –  Zooks64 Nov 29 '11 at 15:22

1 Answer 1

up vote 0 down vote accepted
  1. Is it a Google Apps account? If so, you need to flick some settings in the domain manager: Settings->Calendar->Share all information and/or Share all information, and outsiders can change calendars.

  2. Have you tried going into the calendar settings and checking `Share this calendar with others'?

  3. Wait a while. Google Calendar settings changes often take a while to propagate, I've found (at least with Google Apps). Possibly because the server I'm making my changes on is different from the server that my phone is hitting up.

share|improve this answer
    
#3 seems to be the winner. This morning the Sync Calendar item is there, as are the items I'd added via the web. I've no way of knowing whether any of the actions I took had any benefit, it could be just the passage of time to cause the newly created calendar in my Google account to get noticed. –  Shal Nov 29 '11 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.