Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am trying to backup contacts from my phone (Galaxy S, Android 2.2.1) to Gmail account. The procedure I found on the Internet goes as follows:

  1. Open Contacts
  2. Menu -> Import/Export -> Export to SD card
  3. Menu -> Import/Export -> Import from SD card -> Google (i.e. save imported to Google account)

For some reason I don't have option to use SD card, so I use SIM instead. However, when I import contacts, they save to the phone (there is no prompt where to store them). I changed settings to automatically save contacts to Google and it works for newly created ones, but doesn't affect importing.

Am I missing something? Or could you verify this behavior on your phones?

share|improve this question
add comment

migrated from superuser.com Dec 6 '11 at 14:20

This question came from our site for computer enthusiasts and power users.

2 Answers

up vote 1 down vote accepted

I remember this. When I first got my phone I made the same mistake, setting my contacts to save to my phone instead of Google. I believe I ended up using the free version of MyBackup to backup my contacts, then restore them as Google contacts.

share|improve this answer
add comment

Contacts, by default, that are saved on the device, will sync with the google account ( or accounts ) that are signed in on the device.

If you have contacts on your sim, you can go in to the contacts application, go in to the menu and select "Import/Export", then you select Import from SIM. This will import your contacts that are on your SIM to the account(s) that you are logged in to on the device.

Finally, make sure you have Contact Sync enabled for your account. Go in to the settings -> Accounts & Sync, Select the Google Account you want to sync the contacts and then make sure "Contacts" is checked.

In response to your last comment about "you can save contacts to SIM", I guess that would depend on your device. AOSP (Stock) Android 2.3.5 does not give you the option for phone the device and SIM. Below is a screenshot of all of my synced accounts, and the only option for "unsynced". Since you say you see icons next to some of them, I would be willing to guess you have a samsung device that is running touchwiz. There is a setting that you can change to "always add to 'this' account". Don't bother "linking" multiple contacts together, it is only on the phone side, it does nothing when syncing.

enter image description here

share|improve this answer
    
You're wrong. If you set contacts to be saved on device, they don't sync. –  R Burny Dec 6 '11 at 17:47
    
No, contacts saved to the sim do not sync. If you "add" them to an account they sync. "Saving to the phone" does not save them to an account, so they do not sync. "Saving to phone" is saving them to the SIM card. I have ad multiple android devices, and never has it defaulted to save to SIM/Phone, it always defaulted to my google accounts. –  Ryan Conrad Dec 6 '11 at 19:02
    
also, did you read my answer, I told you how to import them if they are saved on the phone/sim... and it doesn't require you to use a market app to do so. –  Ryan Conrad Dec 6 '11 at 19:04
    
I think there is some misconception. Actually you can save contacts to SIM (sim icon will appear next to the contact), physical device (no icon) or Google account ("g" icon). They will be synced only in the last case. –  R Burny Dec 11 '11 at 14:21
    
see my original post for some more information. –  Ryan Conrad Dec 12 '11 at 14:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.