Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Galaxy S2 that for some reason does not work when it's connected to a 3G network(or at least I think it's connected, there's a '3G' symbol next to my signal meter). When I say it doesn't work, I mean that I don't have any data connection what-so-ever. No internet, nothing.

When my phone is connected with the 'H+' symbol next to the signal meter then everything works perfectly. But the problem is that my phone is constantly trying to use 3G, which of course is useless.

My phone details are:

Model Number: GT-I9100

Android Version: 2.3.3

Baseband version: I9100XXKE7

Kernal Version: 2.6.35.7-I9100XWKF3-CL276555root@DELL101 #2

Build number: GINGERBREAD.XWKF3

If anyone has an idea why this would happen, please give me a shout. It's so frustrating having no data connection for the most of my day. Also if there's a way to just stop the phone completely from trying to connect/use a 3G connection. That would be great.

PS - I'm in South Africa and my carrier is 'Cell C'.

Thank in advance!

share|improve this question
add comment

2 Answers

Airplane mode would kill the 3G connection.... but it would also kill the Wifi connection.

APNDroid can kill just the 3G connection.

As for the actual 3G problem... have you talked to your carrier? Does your phone have to know some sort of preferred roaming list that it is missing?

share|improve this answer
add comment

Well, you could try going into Settings - Wireless and Networks - Mobile Networks - Tick use only 2G networks.

That will disable 3G connectivity.

If you wish to disable mobile data, then un-tick the mobile data option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.