Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy S II running Gingerbread (2.3.5). I tried synchronizing My Calendar with Outlook/Exchange 2010 (Outlook running on Win7) using Kies (over USB).

I started with a clean calendar on the phone and the Kies indeed transferred all the appointments and events to the phone, however there is a problem interpreting the dates. Any appointment taking place on a day of the month up to the 12th - the day of the month is interpreted as the month itself, and the month is interpreted as the day. Thus - March 9 becomes September 3, etc. Oddly enough, March 15 stays March 15.

Any ideas what configuration needs to be corrected, and where?

Thanks!

share|improve this question
2  
Hm, sounds like a localization issue, perhaps. Out of curiosity, what country do you live in, and what language do you have your SGSII set for? Could be a disconnect of some sort between the locale Kies is expecting and the locale of your phone. –  eldarerathis Dec 14 '11 at 14:47
    
Agree with Eldarerathis it sounds exactly like you've got one device set to US date format, and the other set to normal date format. Either the PC or the phone is running with the wrong regional settings, and Kies isn't clever enough to convert as it syncs. –  GAThrawn Dec 14 '11 at 15:49
    
Side note: sync via ActiveSync over the air is much better than USB--if your server supports it. Highly recommended over the Kies method. –  halr9000 Dec 20 '11 at 18:12
    
Sorry for the late response to your help... Thanks for the suggestions. I checked the date format already and both are using normal date format. Any secret places on the phone that this setting could be messed up? I checked in the general phone date settings - couldn't find any calendar specific settings. Sadly, our corporation does not allow ActiveSync with our exchange server... –  mcguinn Jan 24 '12 at 7:02
    
I might try setting the phone to US format and see what happens :-) –  mcguinn Jan 24 '12 at 7:02
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.