Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When plugging headphones into my Droid X, I can listen to music for a little while. The issue will start if the headphones rotate while in place. This somehow triggers an event and my Droid X will start to play the default player, sometimes it will play Songbird...sometimes both. Sometimes when it does this it just keeps playing and pausing music. It seems really messed up on the hardware level. I intend to keep the device, as the only real issue is the default players launching.

My question is this: How can I prevent the default player(s) from launching and playing music ever?

share|improve this question
add comment

1 Answer 1

After doing some more research, I found a thread with a lot of users having the same exact problem:

Their solution is to use either Headset Blocker or Disable Autoplay apps. This seems to have sort of worked. Just make sure that taskkiller isn't disable either of these.

I am still experimenting on how to fix this issue...

Edit1: I still see the same issue even though both suggested apps are running. I believe the taskkiller app may be causing this issue. I am going to try disable it and seeing if this gets anywhere.

Edit2: Still no luck. I am going to try rooting my phone and installing the Autostarts app

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.