Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Baseband version: I9020XXKF1

Current software build number is GRK39F on Android 2.3.6

I seem to have a pretty much unrecognised baseband version of the Nexus S. I brought mine carrier-free in the UK.

There are a bunch of updates listed in this thread on XDA: http://forum.xda-developers.com/showthread.php?t=1063664

But there are 2 versions beginning with I9020, but they have extra letters on the end (no X like I do) : I9020A and I9020.

None of them match up perfectly, what update do I need/any dangers of using the wrong one?

share|improve this question

2 Answers 2

My baseband is ever so slightly different from yours: it is I9020XXKI1 (I think; it's hard to read). I upgraded by following the steps at http://www.androidcentral.com/how-manually-update-your-gsm-nexus-s-ice-cream-sandwich; I am pretty sure that you can't go wrong doing the same. At worst, your phone will refuse to install the thing.

share|improve this answer
    
Thanks, will give it a try tonight. Mine definitely ends with KF1. –  Dunhamzzz Dec 21 '11 at 16:04
up vote 0 down vote accepted

The correct build was here. It's listed in incremental updates 2.3.6 - 4.0.3.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.